Jump to content

Livin' with Linux


Tema
 Share

Recommended Posts

Livin’ with Linux

I wasn’t quite sure how or even if I should document this; but eh. In the end, I figured 'why not'? There could be other Dreamers here who might use Linux as their daily OS, or Dreamers who are thinking about using Linux but aren’t sure about making the plunge and I will welcome all responses and questions and encourage those that use Linux to take part as well. Hey I might need a little help on the way as well. 

What I don’t want to see is this topic devolving into petty tribalistic squabbles, elitism or gate-keeping. I would like this topic to be friendly, not just towards myself but to everyone who posts here. 

In this post I will cover:

  • Introduction
    • Disclaimer
    • I’ve tried this before…
    • Rationale
  • Install Environment
  • Requirements and Considerations
    • Desktop Environment
  • Installing
  • You know that graphics card that you have, mate?
  • You know the NTFS formatted drives you have?
  • Customisation
    • KDE Software Manager
    • Weird Bootup Behaviour
      • Private Internet Access Issues
      • Signal
    • Refusal to Automount
    • DPI Scaling Issues
  • Continuing with Customisation
  • Continuing with Setup
    • Installing Steam
    • Applications that probably won’t run under Linux
    • Applications that do run under Linux

Links to other posts I’ve made documenting my journey:

  • None yet.

Introduction

I am moving over to Linux, as my daily driver. I’ve played around with Linux for Desktop before, I first tried Ubuntu (v6.06) in 2006; when my daily driver was Windows XP. I tried it during my college years and I found the operating system compared to XP to be clunky, outdated, poorly designed, unintuitive, not easy to use, lacking in any compatibility what-so-ever and crashed more often than Windows ME with genuinely unstable hardware. If I remember right, I installed it to a USB drive, and it was useful in one regard; by-passing the College’s Spyware. The teachers/tutors were able to see what you were doing on their screen, see what keys you were pressing and so on, but their computers also allowed you to boot from a USB device (An oversight on their part), this was due to a piece of software within Windows. So booting up a different OS from a flash drive was a good way of getting around it. 

I’ve also played around with the first generation of the Raspberry Pi, which uses Linux. I found the desktop environment to be buggy and the whole thing to be slower than hell. I mean this is to be expected. It is a very low powered credit card sized computer for crying out loud. But without a desktop environment, say as a very small web server it was surprisingly fast and responsive, and suits the purposes that I use it for. 

I will not document anything related to personal security practices or choices, because I never do. At this moment in time, I think the best security is not talking to others about your security and the weakest link in any security system for computers is usually the user.

Disclaimer

If you follow this as a kind of guide; I am not responsible for anything that breaks, or loss of data. In fact I am not responsible for anything you do. Sorry.

I’ve tried this before…

In 2018, I had grown tired of all of Windows 10’s telemetry, I saw it as no better than the Google situation I found myself in a few years prior, and decided to do something about it. I decided to de-Windows my life. Or try. So I came up with a plan; I’d use a dual boot setup, separated on two physical disks, one SSD would have Windows 10 on it, the other would have Ubuntu 18.04 LTS on it. I’d try to do pretty much everything on Ubuntu, and for those applications that didn’t work under Linux, or for my games, I’d use Windows. But I’d try to use Windows as least as possible. Fresh install of Windows, Fresh install of Ubuntu. 

For a little while, this went very well. There were a few oddities; but nothing I couldn’t overcome. I even started using equivalent applications… Although I started running into the same problems that I faced when looking for self-hosted open source versions of Google Applications.

Bear in mind that this is my opinion! A lot of these applications, at least back then, under Linux felt less polished, less graphically friendly, more clunky and less well designed than applications that do similar things under Windows. Windows; through all it’s faults, usually feels a lot more polished and presentable. It feels modern, it's great to look at, and it’s relatively simple to use. It’s like with Android-iOS; Despite being an Android-guy, I feel the same about iOS, for some reason iOS ‘feels’ more polished, better designed and so on. I can’t really explain it. But the thing is; I feel like I own my computer when it’s running Linux, just like I feel more like I own my Android phone than I do my iPhone, despite the fact that I paid for both of them, they’re mine, I don’t feel like I own the iPhone at all, and I’ve started feeling this way about Windows on my PC. I don’t feel like I own my PC. Told you it’s kind of weird to explain. 

There are also some pretty weird problems when it comes to Linux applications. They either don’t run exactly right, or there is something that feels “off” about them, like buying something ‘Branded’ off of Wish. It kind of - sort of - looks like the real thing, but it’s not. This becomes even more of a problem when there are applications that I use under Windows that are licenced and that I’ve paid for, which won’t run on Linux, or there are ‘cheap’ imitations of these pieces of software that run, but either have wildly different interfaces which requires re-learning it all, or doesn’t quite have the functionality, features or support as the main software. Now; I know this could be a version of the sunken cost fallacy but some of the things I’ve described are true for free applications too. 

Take KeePass for example. KeePass is an exceptionally important tool for me, I use it daily as it’s my password manager of choice. It’s Free and Open Source Software. It’s astoundingly brilliant because:

  • It doesn’t store my passwords online.
    • So it's not somewhere on the internet ready for the next big hack
    • Or; perhaps even some kind of master key that a “glow in the dark” alphabet agency can use to crack open any password file it likes
  • I have full control and ownership over the encrypted file that contains all my passwords
  • I never need to fear or worry about paying a subscription for using a cloud service
  • I don’t need to worry about a banking problem that prevents payment from going through and the service wiping my passwords for "Nonpayment"
  • I have personal responsibility over it, and more importantly;
    • I own that file
    • I own my credentials

I don’t need to worry about any of this. The Windows version of this application is perfect, well, almost perfect. The Linux version of the application however is utterly broken, the toolbar for example looks like it’s in 4px font, everything else was all over the place, either too big, too small or in weird mismatching font. Oh and it kept crashing. KeePassXC, a Linux specific fork, that opens the same files and works pretty much the same way was a bit more uniform, but now we’re entering the “Clunky to use”, “Unpolished” and generally unpleasant to use territory again. Especially as it doesn’t have the same functionality in my tests as the real application from Keepass for Windows. But at least it works and has a stable font.

Anyway, it’s difficult for me to really explain these abstract concepts. This isn’t a deal breaker for me, because I can play around with Linux, I own the machine that is running on, and I feel like I can customise the UI of the OS. This is more important to me, and if it bothers me that much I’m sure I can mod it, or put up with it. But I digress…

Back in 2018 with Ubuntu 18.04LTS, I’d get the operating system to the way I wanted it, then a few days later it’d start breaking down. I’d have to spend time and energy to get it back to a stable state, but then an update would come along and utterly break something else. But I fought through it, fixing it as I went along. Under Windows, I was able to share one of my drives across the network whenever my computer is on, useful for my Wife as we often use it for private image and file sharing. Under Ubuntu, it took a lot of wrangling, but I got it working, eventually. It was a victory for me, and it felt good! But again, it seemed that every other day something else would break and I’d end up spending a considerable amount of time fixing it instead of using my computer. I started thinking; why is it that I need to fight with the operating system just to do basic tasks, or even use my own computer?

I’d get things stable again and then there was another update a few weeks later… And the computer could no longer connect to the network anymore. It could see the card, and it knew what the interface was, but it couldn’t see a connection at all, as if the cable was out of the back of the computer. Yet in Windows, it was absolutely fine, but Ubuntu - nothing. I spent about four solid days trying to diagnose the issue and fix it, but nothing did. By all accounts it should have been working, but it wasn’t. 

I tried off and on over the next few weeks to try and get it working but I fell. I fell back to using Windows full time, formatted the drive and left it well enough alone. I swore that if I ever tried this project again, that I would not use Ubuntu. Which is ironic, because I’ve used Ubuntu as a server since and I’ve found it to be delightful to use.

Of course, I’ve been using Linux (as a Server) for a considerable amount of time, and I love it. Compared to the desktop stuff, I’ve never had any issues with Linux Servers. I’ve used Ubuntu, CentOS, Debian, Fedora and others, which I have genuinely found to be pleasant to work with. My first ever server was a home server built from old computer parts, I don’t remember when but it was back when Microsoft sent evaluation copies on CD’s of stuff like Windows Server 2003 via TechNet. Whilst sure it seemed reliable and very familiar but the licensing and the bloat… Compared to the free to use Linux based server distros that were available, for me, it was no competition. Linux won this and I’ve had great fun setting up servers in Linux, including the Raspberry Pi, which still is a small web server that runs on my home network and has done so without fail for quite a while running an application that has partially de-googled my life.

So I wouldn’t be coming at this as a complete and total Linux noob. Especially since 2018, I’ve learnt a lot about Linux outside of the server space, as I’ve been running it as a VM from time to time, to play around with it.

Rationale

I remember that shortly after 2011, my father-in-law, kept singing Linux’s praises and kind of derided me for using Windows to which I told him that I use Windows because the applications I use won’t run under Linux; and at the time, no they didn’t. I distinctly remember him going on about WINE and how it can run every Windows Application under the sun; except this is a misconception, it can’t. I mean let's face it; even Windows can’t even run every Windows Application under the sun, either. But specifically certain applications I relied on would not run under WINE. He didn’t seem to get this, but the only thing I could say to shut him up was “Oh yeah? And how many games can I play on Linux? The answer is barely any. As a gamer, I need an operating system that will run the games I want to play.”

Obviously, about the games, whilst it was true at the time, this simply isn’t true anymore. With the release of SteamOS and the Steam Deck there has been a concerted effort to make more and more games work on Linux, and I can only applaud this, as it is an excellent incentive for gamers to use a less bloated and potentially less privacy invasive and perhaps a more secure operating system.

This could also bring other people to the table too, with any luck. The current market share right now for operating systems on desktop and laptops is: 

  • Windows (75.54%)
  • OS X (14.98%)
  • Unknown (4.81%)
  • Linux (2.45%)
  • Chrome OS (2.22%)
  • FreeBSD (0.01%)

More competition is a good thing, I mean look at Intel and AMD. For years Intel became complacent (and before anyone calls me an AMD shill, I’m an Intel guy, I prefer intel processors), then AMD came along and completely shook that up, now we're starting to see innovation and actually good engineering coming out of Intel again. Internet Explorer pretty much died like the Dodo, yet at one point it dominated the market. Then other, better browsers came out. Healthy competition, alive at last. Getting more and more games compatible with Linux, modernising and making things work, almost completely out of the box under certain distros is a good thing for people who are new to all this. Especially those who cannot and/or do not want to purchase a Windows Licence. 

But that’s not why I want to use it. I love tinkering, I love to customise things the way I want them to be. I also want an operating system that doesn’t report every single action that I do, or bowel movement that I have back to a data collector. Okay, Microsoft doesn’t do that last part, yet, but the sentiment is there. I also want an operating system less bloated. I want an operating system that actually respects my ownership over the hardware. I feel Linux does this.

Install Environment

The basic computer specifications are as follows:

CPU: Intel Core i7-8700K (6 cores, 12 logical processors)
RAM: 4x 16GB DDR4-2666 (CMK32GX4M2A2666C16)
GPU: Asus ROG STRIX RTX 2080 Ti Gaming OC 11G (NVIDIA GeForce RTX 2080 Ti)
Drives:

  • nVME: Samsung SSD 970 EVO Plus (1TB) - Main Drive
  • HDD: WDC WD4004FZWX-00GBGB0 (4TB) - Primary Mass Storage Drive
  • SSD: Samsung SSD 840 PRO Series (512GB) - Primary Network Share SSD
  • SSD: INTEL SSDSC2KW256G8 (256GB) - Secondary Network Share SSD

I plan on installing Linux, in addition to my Windows 11 installation, and I will be dual booting via GRUB (GRand Unified Bootloader). The idea is that I will use Linux as often as possible, resorting only to use Windows as a last resort, or if something is truly incompatible with Linux, but it won’t be my primary operating system anymore.

To do this I will shrink my 😄 drive down in Windows effectively splitting the nVME capacity in half. I will also leave ~94GB for Overprovisioning. I’m not sure if overprovisioning the drive (by allocating ~10% of the drive’s capacity as unallocated space) is necessary or not anymore, I’ve seen conflicting theories, but regardless, this is how I set up all solid state drives I own. The problem with solid state storage (from what I understand) is that the more full it is, the slower it gets as TRIM no longer works as effectively and it allows for better performing wear-levelling (If I am mistaken by this, please correct me). This will ensure that even if I use up all the space, it should operate at a decent enough performance. 

So that splits my nVME up accordingly:

  • 529MB (Recovery Partition)
  • 100MB (Boot, Windows)
  • 428.88GB (Main Windows 😄 Drive)
  • 502.00GB (Unallocated)
    • Out of this, I will section the drive up to the following specifications:
      • 64GB (/) - the actual installation
      • 340GB (/home) - for files, documents, and so on.
      • 4GB (Swap) - I don’t think I need a swap, but just to cover compatibility*. 
    • 94GB will remain unallocated sitting at the end of the drive for overprovisioning)

I also don’t tend to use hibernation. Writing 64GB of RAM to a hard drive would take a while, and writing it every day to the nVME/SSD can’t be good for it. Instead I am far more likely to simply suspend my computer (Put it to sleep), and on rare-occasions, actually turn it off. 

Whilst that day won’t be today, there is a possibility where I will one day completely clean my nVME, or get a bigger one and just install Linux on it, and perhaps build a VM that will have some form of Windows, or something that I can duplicate, spin up, use, and then destroy whenever I need, or don’t need them. Or something like that.

* Rationale: It’s why I still use Virtual Memory in Windows (Although it’s barely anything) with 64GB of RAM, I don’t think I need virtual memory at all. However there are some applications that refuse to run or outright crash if there is no paging file detected, which is a bit nonsensical, but there we go. This is why I’ve assigned 4GB for Linux; just in case there is an application out there or something that requires it, it exists. I don’t normally use all 64GB although I have gotten close in the past, this is extremely rare. 

Requirements and Considerations

Linux is amazing, there’s pretty much a distribution (Distro) and configuration for nearly everyone. In addition to the distro’s of choice, you can have a desktop environment, window manager, either of the two or neither. There’s even a choice of consoles/terminals. I’ve been playing around with installations in my VM under Windows. 

For distro of Linux, I’m very much a fan of chucking myself into the deep end to see if I can float. But I don’t want to go too nuts with it. After speaking to a few people the distro of Linux I’ve decided to settle on is: ArchLinux

Yes; I know earlier, I stated “why is it that I need to fight with the operating system just to do basic tasks, or even use my own computer?” That was back in 2018, not representative of what I think today. My thinking is; if I try to use the operating system as I would normally, then I will come across problems that I will have to sort out, I can document these, and tinker the crap out of it. I will most certainly learn a lot on the way. Maybe the more I learn the quicker I can fix problems. I wish I could give a more detailed explanation as to why. But there we go.

Maybe one day I will use a different distro. But for now, I’m sticking with this one. By the way - if you’re a Linux user; please let me know about your setup, and why you picked it! 

There was a problem that I knew about in advance from reading the ArchLinux wiki, and from what was communicated to me by friends. To install ArchLinux, I was going to need to disable “Secure Boot” from my BIOS. Apparently I can re-enable this later, but I will need to set this up once I have Arch up and running. This isn’t a problem for me, so long as I am aware of it, which I am… Despite saying this. I will still forget to do this. LOL

Another issue I am aware of is that this will fuck with my system clock. Switching between Linux and Windows will be fun, as the clock will be wrong, one way or another. As I live in the United Kingdom, the normal timezone is GMT (or UTC), however in the summer (Like it is now) it’s BST, or British Summer Time, which means it’s GMT/UTC + 0100 (1 Hour). 

Linux sets the hardware clock to UTC, and for lack of a better term, applies a “Mask” on the UI that accounts for the timezone. Whereas Windows stores the timezone modified time as the hardware clock. So for example if the time is: 10:00 UTC | 11:00 BST

Linux sets the HWClock to 10:00 and it just displays the HWClock + Timezone in the UI. If I boot into Windows, however, Windows will assume that the time is 10:00 and will display it as 10:00. Windows just displays HWClock in the UI despite the fact that it too has Timezone recognition. But I understand why.

I prefer Linux’s way of doing things in this regard, and there might be some kind of way of modifying the behaviour of either of them. Either in Windows via some kind of Registry Hack, or in Linux by modifying something else. What I want to preserve is Linux’s way of doing it. I actually use UTC time a lot. Not just in administering servers, but in amature radio too. 

Just as an edit in proofreading before I posted this; this is possible by editing this registry key in Windows:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation\RealTimeIsUniversal

By adding a DWORD value with hexadecimal value 1. (Source: Here)

Desktop Environment

A desktop environment is basically the overall GUI of the OS, in very overly simplistic terms. I’m somewhat aware that you can maybe run an installation of Linux without a DE and use a Windows Manager instead, and of course you can run it completely in command-line. Not for me though; I think. Let’s stick to one thing at a time. I will be using a desktop environment. Although I will admit the things people do with these things on r/unixporn is orgasmic to look at by people far more talented than I.

As for which one; there are a myriad of choices. So it comes down to what I am looking for. I am looking for something that is highly configurable, and customisable, something relatively modern and perhaps a little familiar. I don’t particularly care if it’s lightweight or not, I certainly don’t care if it’s designed for low-end systems. I want something that I can be comfortable with and that pretty much comes down to GNOME and KDE Plasma. 

I’ve used GNOME before, but I’m not particularly a fan of it. It’s quite customisable with it’s extensions and what-have-you. There’s nothing wrong with it, if you like GNOME or if that’s what you’re used to, and so on. It’s certainly modern and has a lot of customisation for most people. It comes as default, as far as I am aware on Ubuntu installations, which is okay if you’re looking for something that pretty much runs out of the box. It almost feels like it was designed for a tablet or something and it’s not quite as customisable as I would like. It’s not my cup of coffee.

KDE is an unknown quantity to me. I’ve never used it, at least not knowingly. I’m told it’s very customisable and from what I’ve seen it’s familiar and looks relatively modern. 

So I’m going to choose KDE

Installing

Knowing what I wanted and how I was going to go about it, with everything relatively planned out, I went to https://archlinux.org/download/ and used a torrent to download it. I then verified the checksums with what was displayed on the webpage, and when I was happy with the result, I used Rufus https://rufus.ie/en/ to create a bootable USB drive.  

The process was actually very simple, I mainly stuck to default settings and within moments, the USB drive was created. 

If you want to do this, I highly recommend reading at the very least some basic articles on https://wiki.archlinux.org/ you can also keep this bookmarked, as it’s a wealth of information. You can pick up extremely cheap USB drives from Amazon nowadays (and no, I am not talking about ‘2TB for $10’ or whatever, those are scams) but like a Kingston DT100G3/64GB is only £8 or so in the UK, or a (in my experience) slightly more reliable SanDisk Ultra Flair 64 GB USB 3.0 is less than a tenner (£10) in the UK [Not Affiliated!] 

They’re a bit slower than one would expect, but the Kingston one makes a fantastic medium for installing operating systems from. Of course if you have a spare flashdrive kicking around you can just use that. You don’t really need a massive one either, 8GB will do. You will also need an active internet connection - or at least I certainly did. 

Once the drive is made, and the nVME was repartitioned to the specifications I laid out above where I have 502GB of unallocated space. I could partition the space in Windows for Linux but seeing as I will have to format it for Linux’s file system later anyway, I don’t really see the point. I’ll just do it with the install process. Do I wish that Windows could format in a Linux Filesystem format, and thus be able to read and access it? Absolutely not.

From there on, I restarted my computer and booted up from the flashdrive. Well. I tried to, but I had forgotten to turn off Secure Boot. Yep. Despite it saying VERY CLEARLY in the Wiki, and KNOWING FULL DAMN WELL beforehand, I still forgot to do it. 

D’oh!

So Restart > Enter BIOS > Disable Secure Boot > Save and Exit.

So I rebooted, booted from flash and was presented with a menu and a countdown timer for 15 seconds, with my computer making the loudest and most obnoxious beeping ever heard. Like a bomb timer was counting down or something. Ominously. I just hit enter on “Arch Linux install medium (x86_64, UEFI)” and let it load up. 

Now; and I was pretty much dumped at a command line interface (CLI), to a graphical user interface (GUI). Think: DOS but way more awesome. I am aware that there is a kind of installer script which can be accessed by typing:

archinstall

But I decided to do it the manual way, and there are plenty of videos on YouTube for this, but I mainly followed the wiki and used the videos in the beginning as references. This was my step-to-step installation procedure. Installing an OS via command line can seem very daunting at first but the process was smooth and actually very easy as well as oddly satisfying. 

Because my primary monitor is 4K the text was pretty small, I either needed to get my eyes checked - again, pull out a magnifying glass, or change the console’s font. Well I’m not doing the first two; so I changed the console font-size. I wish I had taken pictures, actually. It was comical. So I typed:

setfont ter-132n 

And once I hit the ENTER key, the text became far more readable. The next thing I wanted to do was to see if my internet connection “Just worked”, so I ran the command:

ip -c a

Which showed me that my “eno1” was connected and showed my local IP Address. With my setup here, I need to be absolutely sure that I have network level access, and the output confirmed that I did, which was expected. So the next thing to test was, whilst it was connected to the router and had been given an IP Address, did it have internet level access and could it resolve domain names? So I typed:

ping archlinux.org -c 5

And sure enough, I was getting responses, with no packet loss, which told me that not only did my computer have an internet connection, but that it was also able to resolve domain names. For me this is a big deal as I have had issues in the past where pinging an IP Address will work, but a domain name won’t work. This is because I have a custom DNS, which I’m not willing to go into any detail about (See last paragraph of Introduction for the reason). 

Next I needed to verify if I was booted in EFI mode. To do this I typed:

ls /sys/firmware/efi/efivars/ 

And I saw a good list of things that seemed to have some kind of UUID-number appended to each of the objects. This means that I am indeed in EFI mode.

The next thing I needed to do was to set my timezone and sync my clock which I accomplished by typing:

timedatectl set-timezone Europe/London

And then:

timedatectl set-ntp true

I can then check the status of this by typing:

timedatectl status

After comparing it with my radio-controlled clock, and found it to be accurate, I decided that I was happy with this. 

NOTICE: This command only applies to the UK, if you were doing this you would need to check which timezone is applicable for your country/area. To do that you’ll need to run: 

timedatectl list-timezones

Next I want to make sure that the keyboard layout for this session is set to British. The default is American; and the problem here is that some of the keys are in different locations. For example, @ and “ are switched, and ~ for the American’s is ¬ for us British folk. I’m sure there are other differences but I can do without typing something and stumbling over the fact that the keyboard layout is screwed. So to change it I just put in:

loadkeys uk.map.gz

If you were to do this you’d need to type “ls /usr/share/kbd/keymaps/” and tab through, if you’re using a laptop or PC you’d need to go to i386 and tab through again and depending if your keyboard is a QWERTY or QWERTZ keyboard go into that folder and find your map file, then replace uk.map.gz with your map file of choice, or use the whole folder name, so in my case “loadkeys /usr/share/kbd/keymaps/i386/QWERTY/uk.map.gz”. 

So far this has been very easy, but now we need to get on with it, we have an nVME with space we need to partition, but we also need to know how Linux defines the drive, we can’t visit (Access) the property (The Drive) and put up new walls (Partition) there if we don’t know the address. So I need to type:

lsblk

Here I see all the drives connected to my computer. In my case I am only interested in ‘nvme0n1’ I can also see the existing partitions set at ‘nvme0n1p1’, ‘nvme0n1p2’, ‘nvme0n1p3’ and ‘nvme0n1p4’, this is important, because these are partitions that I want to leave WELL alone for now. If I touch any of these I could very well wipe my Windows 11 data which is not what I want to do at this stage. 

This is where, if for whatever misguided reason you're following this as a tutorial, that you need to stop doing so blindly and consider what you’re doing. Your setup will probably be different from mine. 

I will also need to see which of these partitions is the EFI system (I know it’s the 100M partition) but it doesn’t hurt to make sure. With that I run “fdisk -l” just to see which partition it’s on and in my case it’s ‘nvme0n1p2’ so I will make a note of this for later because as it’s a dual boot set up, I am going to need to make some careful modifications.

With that all done, I moved on to the next command, and cheated a little. I was going to use a little graphical interface within the command line to partition the drive, so with that I typed:

cfdisk /dev/nvme0n1

Which also told me which partition the EFI System was present on. Oh well, triple check, then. It’s still ‘/dev/nvme0n1p2’. From here I went down to the free space and pressed ENTER for “New”. Sticking to the plan, this was going to be my ‘root’ drive for Linux, so I set this to ‘64G’ (nvme0n1p5). I did the same for the home partition except I set that to ‘340G’ (nvme0n1p6) and then finally the ‘Swap’ partition which I set to ‘4G’ (nvme0n1p7) as per the plan. I pressed the right key a few times to get to ‘Type’ and set this 4G partition to “Linux swap”, then scrolled to the ‘Write’ button then to ‘Quit’.

Easy as that. Job done… Well not quite, because now I need to format these new partitions. For me this was as simple as:

mkfs.ext4 /dev/nvme0n1p5

And…

mkfs.ext4 /dev/nvme0n1p6

For the swap partition I ran:

mkswap /dev/nvme0n1p7

And then

swapon /dev/nvme0n1p7

Next I am going to want to mount these partitions to various locations, and this will be a string of commands ran one after the other for my set up:

mount /dev/nvme0n1p5 /mnt
mkdir /mnt/home
mount /dev//dev/nvme0n1p6 /mnt/home

I can then verify that this has worked by using “lsblk” again. 

Next; I am going to select the fastest mirrors. “Mirrors” are servers which host the same files ready for download. So another string of commands:

cp /etc/pacman.d/mirrorlist /etc/pacman.d/mirrorlist.bkp
pacman -Sy
pacman -S pacman-contrib
rankmirrors -n 10 /etc/pacman.d/mirrorlist.bkp > /etc/pacman.d/mirrorlist

This took a moment as it tested the download speed of the mirrors until it completed with no notice. After this I ran:

pacstrap -i /mnt base base-devel linux linux-lts linux-headers linux-firmware intel-ucode sudo nano vim git neofetch networkmanager pulseaudio

Note: If you have wireless you might want to look at the documentation, and if you have an AMD chip you might want to replace intel-ucode with amd-ucode. When promoted I left it set to default and then confirmed the download. This took a hot minute for me, but I waited. With that installed, next was to generate the file system table (FSTAB):

genfstab -U /mnt >> /mnt/etc/fstab

I then verified it:

cat /mnt/etc/fstab

Now I needed to somewhat leave the live system and enter into the actual installation, for that I typed:

arch-chroot /mnt 

And the console changed a little to show that I was now operating within the installation. I won’t be adding a root account, and in fact later I will be locking things down and hardening my installation that unfortunately, I’m not going to go into, ever (See the last paragraph of the introduction as to why) but suffice to say, you will need to make a user account, and you might want to give it some kind of access level in my case I typed:

useradd -m USERNAME

Where USERNAME is my username in lowercase letters. To then set a password on this account I typed:

passwd USERNAME

And set my password of choice, for now. After this I gave the account some privileges that I was going to need by typing:

usermod -aG wheel,storage USERNAME

A made some changes to my sudo config file, which I’m not going into. So moving swiftly on, I edited the Locale of my system by typing:

nano /etc/locale.gen

Then I scrolled all the way to en_GB.UTF-8 and removed the # in front of it, to uncomment it. After that it was time for another string commands:

locale-gen
echo LANG=en_GB.UTF-8 > /etc/locale.conf
export LANG=en_GB.UTF-8

With that done, the next step for me was to set up the hostname for the computer (The Computer’s name) which in my case is TemArchDesktop, as I’m looking at that laptop of mine and thinking that I might go full balls to the wall with that one and just outright install Linux on it. But for now, lets work with this. So I typed: 

echo TemArchDesktop > /etc/hostname

Then I needed to edit the hosts file, after checking /etc/hostname with ‘cat’. For this I typed out:

nano /etc/hosts

Where I added the following lines to the end of the file:

127.0.0.1	localhost
::1 		localhost
127.0.1.1 	TemArchDesktop.localdomain	localhost

And then saved and closed. I set up the timezone/region within the installation and synchronising the clock by doing the following:

ln -sf /usr/share/zoneinfo/Europe/London /etc/localtime
hwclock -systohc

Now; because I am dual booting, I am going to want to set this up very carefully. I’m going to be using the GRUB bootloader which will allow me on boot up to pick if I want to boot into Arch or Windows. The default will be Arch, with a 5 second countdown, so if nothing is pressed it will just proceed to Arch. That’s the idea anyway. I made a note of the EFI partition that I made earlier, (/dev/nvme0n1p2). So, to get started I will enter this string of commands:

mkdir /boot/efi
mount /dev/nvme0n1p2 /boot/efi
pacman -S grub efibootmgr dosfstools mtools
nano /etc/default/grub

In here, I scrolled all the way to the bottom and removed the hash before “GRUB_DISABLE_OS_PROBER=false” so that I could use an OS Prober to configure my GRUB with. Next I needed to install OS-Prober and set up the GRUB Installer like so:

pacman -S os-prober
grub-install --target=x86_64-efi --bootloader-id=grub_uefi --recheck
grub-mkconfig -o /boot/grub/grub.cfg

During the second command I could see that it had installed with no problems reported and during the last command I could see that it had found the Windows Bootloader. Next I wanted to enable the NetworkMananger service as I was planning on rebooting, so I typed:

systemctl enable NetworkManager.service

And then “Exit”ed out of the installation. I then typed:

umount -lR /mnt

Which unmounted everything, typed ‘Reboot’ and when the computer rebooted I could see the GRUB boot menu which had what I expected. I double checked my Windows 11 installation, and it seemed to still be working. I rebooted again and went to Arch Linux. But now I needed to install a Desktop Environment, because when I came into Arch I was at the command line screen. 

I logged in with my user account and made sure that the pacman database was up-to-date by typing:

sudo pacman -Sy

This required me to enter my password, but immediately after I entered this command:

sudo pacman -Sy xorg xorg-xinit xterm plasma plasma-desktop plasma-wayland-session kde-applications kdeplasma-addons sddm 

And just pretty much pressed enter through everything and confirmed my installation choices. This took a good while to do. If you’re doing it, and have a slow internet connection, I would recommend putting on a cup of coffee or something. After it was complete, based on what I understood from what I had seen and what I had read, I needed to set it up a bit more, so I just typed:

sudo nano ~/.xinitrc

And added “exec startkde”, saved it and closed it. Then I needed to run this command:

sudo systemctl enable sddm.service

Then that was it. Reboot again, let it boot back up and this time I was presented with the graphical login screen! 

Installation Complete.

I did not run into any problems at all during the installation process, it was smooth and really easy. I enjoyed setting it up manually and I felt quite accomplished in doing so and so my next task now was to jump straight into it and start playing around with - oh not so fast. Literally. 

Everything went hyper slow once I logged in, I would wait a good hot minute for anything to do anything. I noticed very quickly that if it had something to do with any level of animation, the computer - my computer - would start absolutely shitting the bed. Then I made the mistake of drifting my mouse into the top left-hand corner of the screen… Everything seemed to freeze… TIME, ITSELF, STOPPED! … On the computer that is, the clock stopped. It didn’t take me very long to figure out what was going on, I had seen this before a long time ago in Windows.

You know that graphics card that you have, mate?

I don’t particularly care what drives I use for my NVIDIA graphics card, so I just went to the Nvidia website and downloaded the driver from there. I know this is potentially a thing that a “Heathen” would do, go and download proprietary drivers. However this didn’t exactly work. I went into the console and ran it, and in the end I had to go resort to pacman and typed:

sudo pacman -S nvidia nvidia-settings nvidia-utils 

After installing I ran ‘nvidia-modprobe’ as instructed and nothing happened. Thinking that it was all installed, and all I needed to do was reboot, I rebooted…

And then my desktop environment wouldn’t load… “Oh CRAP!” I exclaimed thinking I already fucked it. Not even ten minutes after installing it, it seemed to be stuck on the preboot screen, just after GRUB and for some reason not going any further. But then I pressed ALT F2 and a console opened up on my second monitor, whilst the first monitor remained frozen. After logging in and running:

journalctl -b 

I noticed some error messages, specifically “SDDM failed to read display number from pipe” or something like that. After doing a bit of searching on my laptop, I found a topic on reddit. And apparently I needed to make a modification to my mkinitcpio config. I also looked at the Arch Wiki (It’s your friend!) With haste I fired off the command:

sudo nano /etc/mkinitcpio.conf

And added;

i1915 nvidia nvidia_modeset nvidia_uvm nvidia_drm 

To the “MODULES=()”, within the brackets, and I then fired off this command:

sudo pacman -S nvidia-lts
sudo mkinitcpio -P

And then I rebooted. When I came back into Linux, I could see the login screen to my desktop environment was back. Everything seemed to be working perfectly.

You know the NTFS formatted drives you have?

Oh yeah; I actually forgot to deal with this earlier. By default it seems Arch doesn’t know what to make of NTFS (New Technology File System) this is a simple fix; just by typing:

sudo pacman -S ntfs-3g 

This installs the relevant driver. 

Customisation

Although I really don’t like that corner thing… The thing where you move your mouse over there in the corner of the screen and suddenly it’s like an alt-tab in Windows 11. I could be typing away at something - like this post for example - and my mouse would drift over up there either by knocking it or whatever, and in the middle of typing - boom - this great big thing showing me all the open windows pops up. This did not happen in any of the VM tests I did, so it was not something I had expected. 

The first thing I was going to do before doing literally anything else was disable the crap out of it. I don’t hate it, and in fact I can see why something like that might be useful or even loved, but for me right now, it’s not for me. Thankfully this is easy to do. Under System Settings > Workspace > Workspace Behaviour > Screen Edges you can select the corner that has something assigned to it. It can be assigned to a number of different things, and honestly that seems to be a real neat thing for those who want to utilise it. There is also the option to disable. Which I did.

After that I went and sorted out my security settings, and did my typical set of hardening stuff. I do this under Windows, and I do this under any Linux Server I set up. This is my default thing with new computers… Well unless it was my laptop. The first thing I did there was format the nVME in there, and installed a fresh copy of Windows 10, no bloatware, no crap, no potential spyware, Acer. 

I noticed very quickly that I was able to install Desktop Widgets. I do like good ol’ little widgets. I used to have them with Windows Vista, and until they were removed, Windows 7. I even brought them back under Windows 7 and I think for a brief time under Windows 10 by using a program called “Rainmaker”. I probably won’t use them permanently, but I have them for the screenshot I made. 

Screenshot_20220626_024446.jpg

My first noticed issues with the OS was the following:

  • KDE Software Manager: I cannot update any of the KDE installed applications, plugins or anything through the KDE software manager. 
  • Weird Bootup Behaviour: Konqueror, Konsole and a file manager window all seem to open on bootup. I don’t know why.
    • Conversely my VPN (Private Internet Access) doesn’t load up on bootup, despite being told to load up on boot up.
    • Neither does Signal. 
  • Refusal to Automount: Despite selecting it in my operating system, my hard drive and SSD’s don’t automatically mount on boot up, and I have to reenter my password just to mount them - individually. 
  • DPI Scaling Issues: I have two monitors; one is 4K the other is 1080p. Both require different scaling sizes. The 4K one requires 150%, or so, the 1080p requires 100%. Despite this, if I change it for one, I change it for both, and I can’t seem to do this, whereas Windows can do it effortlessly. I either have to put up with everything looking ridiculously small on one screen, or ridiculously large on the other. As it stands I need 200% magnification in Google Docs just to see what I am typing. 

So before I was to get cracking with customising my experience, I wanted to fix these issues. 

KDE Software Manager

I can’t really remember what the problem was specifically, but basically the only things that showed up in “Discover” was “Application Addons” and “Plasma Addons” there was nothing to denote software packages or anything like that. Additionally the updater just straight up didn’t work, and “Installed” only showed things in those two categories. I think there was an error message saying something along the lines of "Please verify internet connectivity", of which my computer was connected to the internet. This was an easy fix, however. In Konsole I ran the following command:

sudo pacman -S appstream-qt packagekit-qt5

And just like that, after inserting my password, it downloaded and installed the packages and the Discover application now worked properly. Easy as that.

Weird Bootup Behaviour

The first thing I wanted to do here to diagnose this, was to see if it did this only on a fresh boot, or if logging out and then logging back in would do this as well. I made sure that all applications and windows were closed before I did the experiment. After doing this, only Konqueror and the file manager loaded, trying to mount one of the drives - and asking for a password to do so. The only thing in the settings under Workspace > Startup and Shutdown > Autostart was my VPN application, nothing else. 

So I went to the Settings > Hardware > Removable Storage > Removable Devices and unticked everything that would automount on “Login.” Then rebooted. After it rebooted, and I logged in, Konquerer was the only thing that seemed to load up automatically. So my problem seemed to be multifaceted. 

After looking around the internet, the solution here was to go into Konqueror’s settings and under KDE performance, untick “Always try to have one preloaded instance”. After another reboot, I could see that this problem was now resolved. So an easy fix.

Private Internet Access Issues

For some reason my Private Internet Access (My VPN of choice) doesn’t seem to start up at bootup. However I double checked the in application settings to see that it should load up on boot up, and I double checked the autostart settings within KDE. For good measure I went to the properties page of the PIA application and checked “Is executable”, in case there was some weirdness there. 

A reboot later, and this seems to have fixed my problems. PIA connects before I’ve even logged in, and the GUI loads on login. 

Signal

Signal is a WhatsApp Style Messenger application that I use extensively. Whether it be internal communications with staff on EcchiDreams, friends or family and so on, most of my time with an IM platform is not spent on Discord, it’s spent on Signal. So Signal is extremely important to me. 

Doing what I did to make Private Internet Access’s GUI to load on login, going to KDE Settings > Workspace > Startup and Shutdown > Autostart, I added Signal and used the properties page to make the application an executable. After a reboot, Signal started up on my second monitor, where I left it. 

Fantastic. 

Refusal to Automount

As I discussed before, two of my SSD’s are required to be network shared, that is, they need to be available over the network. Yes, I could just slap them in a NAS and be done with it, and one day I may very well use a NAS for this purpose, but for right now it’s controllable by being in my computer. If I don’t want people or potential hackers from accessing it whilst I’m not at the PC, I just shut down my PC or put it to sleep (I go out of my way to disable WoL - Wake on LAN). 

Having them mount automatically would be less of a headache, especially if they’re going to be network shares. In addition my 4TB HDD is my bulk-storage drive. Whilst it’s not as important to have this automatically mount, it would be nice for it to automatically mount if I decide to install and run Steam on my Linux installation (And you bet I’m going to do that!) as this is where all my games are installed. 

So getting this fixed is important to me. I do not want to disable asking for passwords to mount or unmount removable devices, such as flash drives, SDHC cards, MicroSD cards and the like. But I feel that a suitable compromise would be that the drives in my machine already should be drives that I consider trusted and should mount automatically without a password.

After a bit of reading, and looking around I believe I know how to resolve this issue.

I will have three mounts todo: 

  • HDD: 4TB - Bulk Storage Drive
  • SSD: 512GB - Share Drive 01
  • SSD: 256GB - Share Drive 02

This is where I dare say it, somewhere the Wiki kind of fails, because it suggests that I should mount the drives as (for example) /dev/sda - from what I understand, whilst technically true, this is actually very bad practice. As on boot up, what gets assigned where can actually change. After watching a video from Linux Crash Course, I pretty much had it confirmed. I need to mount a partition by the UUID, not where the system has put it. The linked video will explain why.

First I will go into my Konsole and get root privileges. Then I will need to make a note of my UUID codes for my drives; to do this I run the following command:

blkid

As I have labelled my drives, seeing which ones I need to mount is trivial. I select the UUID codes (Everything within the quotes (“)) and paste them into a notepad. Then I will make the folders within my /mnt folder, so I go into mnt and create three new folders for my drives: bulk, peeps, neptem respectively. To do this I typed:

mkdir bulk
mkdir peeps
mkdir neptem

I will navigate to /etc and then backup fstab to fstab-bkp or something, in case something goes wrong. Then I will nano into fstab to edit it. Simply; I leave everything in there alone, and just go to the bottom to add the following:

# 4TB Bulk HDD
UUID=0123456789ABCDEF   /mnt/bulk       ntfs-3g         defaults        0 0

# 256GB NepTem SSD
UUID=0123456789ABCDEF   /mnt/neptem     ntfs-3g         defaults        0 0

# 512GB Peeps SSD
UUID=0123456789ABCDEF   /mnt/peeps      ntfs-3g         defaults        0 0

To test this I ran:

mount -a

And it seemed that all three drives mounted. A reboot later and all the drives mounted without asking me for a password, and if I put in a flash drive, it asks me for the password before it is mounted. All in all this is a result, and I got it to behave the exact way that I wanted it to behave. So a bit of a more involved fix, but easy nonetheless. 

DPI Scaling Issues

Windows 11 has infinitely better support for this than Linux seems to, in my opinion. In Windows my 4K display has a DPI scaling of 150% whereas my 1080p display has a DPI scaling of 100%. For some reason, by default Linux has the option to change the scaling in percentage points, but it’s global, as in it applies to both monitors. This either has the effect of making everything comically tiny on the 4K display and normal on the 1080p display, or makes everything normal on the 4K display and comically large on the 1080p display.

I’ve pretty much tried everything here. I started by setting it to 125% sort of compromise and meet in the middle kind of thing. After I actually stopped to think about that, and could see that it wasn’t working, I considered that the idea of ‘compromising’ by setting it to 125% was absurd in the first place. I tried setting the 4K resolution down from 3840 x 2160 to 2560 x 1440 and if we’re talking about absurdity that was quite something else. Whilst things looked a bit better (IE: It was actually readable) the font had this annoying blur to it. It wasn’t sharp like I was used to. 

Whilst the Documentation kind of doesn’t make a lot of sense to me (I kind of start glossing off whilst trying to read the damn thing) I found a tip on Reddit that seems to do the trick. First I need to know what my monitors are assigned as. In my case the 4K display is DP-0 and my 1080p display is HDMI-1-1. Apparently I just need to run these two commands:

xrandr --output DP-0 --scale 2x2
xrandr --output DP-0 --scale 1.5x1.5

Oh dear God, no. This caused everything to utterly go microscopic, and it caused the second display, to display on the second display, but also on the first display as well. So I could see the contents of my second monitor, on my first monitor like a really badly implemented picture in picture mode, and see it play out on the other monitor as well. Trippy.

I discovered quite by accident that I seemed to be running X11 instead of Wayland, which is not what I wanted at all, so I logged out, switched back to Plasma Wayland and oh shit… The problem I had earlier somewhat resurfaced. Where I would get something to the effect of:

Quote

Starting version 251.2-1-arch
/dev/nvme0n1p5: clean, W/X files, Y/Z blocks

On my 4K Monitor, where as on my 1080p monitor, I’d get my desktop environment. Oh and the display settings on the 1080p monitor cannot see my 4K monitor at all, but at least “Scaling” isn’t a global option anymore.

Interestingly on a reboot, the 4K display works fine, it shows the login screen, but as soon as I login the behaviour is repeatable. After some searching on the internet, I stumbled onto the knowledge that SDDM doesn’t exactly play very nicely with NVIDIA. Apparently what I needed to do was edit the kernel commands at boot up to include:

nvidia-drm.modeset=1

So I rebooted and pressed “E” on the GRUB menu, because I wanted to test it before I committed to it. And I am glad that I did. The system booted, as per normal, I got to the logon screen which displayed on the 4K monitor, I entered my password and then I went back to the same screen on the 4K monitor that shows ‘Starting …’, except this time the 1080p Monitor was completely black, and the computer was not responding. I had to force restart.

I don’t know what is causing this, but the only “Fix” I can do for the time being is go back to X11 and admit that I have lost this battle. The problem here I think doesn’t help from the fact that my 4K monitor is plugged into my graphics card, whereas my 1080p monitor is plugged into my motherboard (Using the Intel UHD Graphics 630) that comes with my CPU.

Whilst I have lost this battle, I haven’t given up, so the war isn’t lost. But if anyone has some useful pointers to throw at me, please feel free to. I’d love input. Going back into X11 does seem to resolve this issue perfectly. I don’t even know if Wayland will fix this issue, but it was my intention from the beginning to use Wayland. I guess I started using X11 and didn’t realise it. 

Continuing with Customisation

I messed around with the theme settings which then broke down into various different areas of the desktop. With all of the faults of Windows Vista, there was one thing Microsoft did right by it, and that was the Aero Glass theme, how it had semi-transparent bits of the UI which kind of looked like glass. As such I changed a few things and downloaded a theme. I downloaded a WM Theme called “Glassy” and I’ve kind of mixed and matched the icons, a little. I’ve also altered the Konsole so it looks like a dark slab of glass. It’s not all the way to where I want it, but it’s getting there. I am likely to play around with this more, because there is a lot you can customise. Even the “Start Bar” which is called a Dock (Panel) that goes along the bottom of the screen can be pretty much completely customised. It’s kind of insane really; here’s a taste of what I’ve done so far:

Screenshot_20220701_105053.jpg

Although I couldn’t tell you what I did individually to make it the way it is, there’s kind of a lot, and once I started, I didn’t stop to document it. Perhaps I should have installed OBS and recorded it for note keeping purposes. I will do that next time. But let's put it this way, I started tinkering with it earlier and before I knew it several hours had passed. Honestly, it’s mind blowing and I love every single thing about it.

Continuing with Setup

There are a few more things I wanted to do to make this my daily driver.

Installing Steam

First thing I did was install Steam, as you can see in the previous screenshot, I was successful. Although Steam has a sick sense of humour. Even though I had pointed it at the drive that contains all of my Steam games and such, it apparently needed to download updates for 224 of them (According to SteamDB I have 402, so I think 224 is what I have installed). 

Installing Steam is not as straight-forward as going to Steam and downloading it, at least not in my experience. I had to edit /etc/pacman.conf and uncomment (Remove the “#”) from the following two lines:

Quote

 

#[multilib]
#Include = /etc/pacman.d/mirrorlist

 

I then did a sudo pacman -Sy, and then sudo pacman -S steam and selected the Nividia option. It then pretty much installed it, I ran it, it updated (Which is what it does under Windows), logged in and I was in. So pretty much just as simple, with a slightly different route. Not too bad at all. 

The one concern that I do have with Steam is that even when idle (Not downloading anything) the CPU usage was between 11% and 20%. Now it could just have appeared to be idle and was doing stuff in the background that it wasn’t making me aware of, I don’t know. After all these downloads are complete, I would be very interested to see if this issue has resolved itself ot not. 

Steam Chat also seems to work just fine. But to be honest I would expect Steam to work. The question is, does any of the games that are tagged as Linux compatible work, and if so, do they run properly? 

First test was with ARK: Survival Evolved; it started up and I got to the menu, but as soon as I went into the options screen, the game froze. The sound continued, but nothing I did made any difference, and when I tried to close the game, it refused to shut down. Eventually it showed up as (Not Responding) and I was able to just terminate the process. Not a very good start. I’m inclined to believe that this could be a bug somewhere along the line.

The second test was with a game by Egosoft called X4: Foundations. The loading times were excruciating, but this is not really all that much different under Windows. The game, once loaded, ran flawlessly. I saw no discernible framerate droppage even in combat. So I have no complaints there. Egosoft clearly did a good job here especially when it comes to support. 

The third test was with Kerbal Space Program, which again seemed to load and run just fine. I was even able to view my objects which were in orbit around Kerbin, so that seems to be all good too. There were no framerate drops in my test.

The fourth and final test was with Euro Truck Simulator 2. Whilst the game loaded fine, and seemed to work, graphically there was something wrong from the offset. It was like the game was stretched over two monitors. Nothing displayed on the second monitor, so everything was cut off on the first one. But I was able to change the resolution in the options and things snapped back to normal. Almost normal, anyway. In the game itself it seems that the graphics were running on the lowest possible settings. After taking a look in the settings again, I could see that custom settings were being applied and they were abysmal. After switching it back to “Ultra” I could see a remarkable improvement, and things seemed to run perfectly with no framerate drops. 

Other games on my Steam list seem to be indie titles, games that wouldn’t push a paper bag, let alone this system. Or they’re games I haven’t downloaded like Deus Ex: Mankind Divided which is well over 70GB. I’m going to pass on downloading that for now.

Out of all the games I have on Steam (~402) only 149 are compatible with Linux, and what I mean by that is by the use of Steam’s option to show only Linux Compatible Games. This isn’t great, but it’s a lot better than what used to be like. Unfortunately; this justifies my reasoning for keeping Windows 11 as a dual-boot option, at least for the time being. But this isn’t really incompatible with my idea anyway; which is to use Linux as a daily driver and if I want to do any gaming, switch over to Windows. My blip with ARK: Survival Evolved is unfortunate, but not being able to play Elite Dangerous, Space Engineers and other such games in my Steam List is disheartening. I am aware that there might be the option to faff around with getting some of the other games to run, but this isn’t something I’ve looked into yet and could be a topic of a discussion, or even a later post. 

I still think that by getting more and more games to run on Linux is a fantastic thing. The fact that people are even getting games to run on Linux, that are so old they’re not even being developed anymore is amazing, and overall this is a very positive step in the right direction for Linux to be adopted by more and more people. In my opinion. Is it there, yet, though? No. But with the Steam Deck (Aside from the recent controversy over downgraded SSDs) it’s only a matter of time, I feel. The Steam Deck has the potential of having the biggest games library that any console has ever had, ever. With Valve working on Proton I’d expect to see more and more games on Steam being available to Linux as a whole. 

I have noticed that there is an option to run Steam games within the launcher using a compatibility layer (Proton), however in the tests I have done with this so far, this doesn’t seem to work for me. This could be something I need to further look into, I probably will. But not today.

For more information on Proton and Steam Games Compatibility with Linux goto: https://protondb.com/

This is a community driven database with people even offering advice on how to run games that crash, for example Cyberpunk 2077. Sure it’s not as easy as it is in Windows; it’s a bit more involved, but hey… It’s still a lot better than what it used to be, and there is a clear and concerted effort to improve things. I think this project has a lot of potential and I think it’s important going forwards for Linux adoption. 

Applications that probably won’t run under Linux

Visual Studio Community is an application that I use to code in C#, JS, and so on. The next generation project I am working on with my brother in law uses VSC quite extensively. However I don’t believe this will run properly on Linux at all. Which means I will need to use Windows for this. This isn’t a major problem.

Photoshop CS6 is an application that I use for photo editing, and dealing with my photography. I still have a licence key which I purchased for this product, and I’ve refused to “upgrade” to Photoshop CC. Given the fact that it works almost flawlessly under Windows 11, I see no reason to “upgrade” and move from what was effectively a perpetual licence to a monthly subscription. Fuck that. There might be a way of running this on Linux, but I don’t know how stable that would be. There are Linux alternatives and even SAI but it took me years to work out how to use Photoshop properly, I don’t want to learn a whole new interface and way of doing things for something that nowadays, I rarely really do in the first place. 

Microsoft Office 2019 and Microsoft Visio 2019; again, I still have full and legal licence keys for it, and did not “upgrade” to Office 365 for the same reason I didn’t do so for Photoshop. However I usually use Google Docs which is indiscriminate as far as I can tell, and LibreOffice/OpenOffice are both things that apparently work just as well as the Microsoft solution at a 100% price cut. 

[BRAND NAME] Antivirus, seems to only be compatible with Linux. I’m usually careful about what sites I go on and what I download, and typically, I have my own security policies in place to mitigate risks involved with such things in the first place. That said, ClamAV is an option if I want one, but I probably won’t. That said, I have an active subscription to [BRAND NAME] that is for a period of 3 years or something silly like that. I don’t see why I can’t keep this running on my Windows Installation. 

Notepad++ has been my text editor of choice since about 2012/2013. It doesn’t seem to natively run on Linux. The alternative is Notepadqq which is a clone (Apparently) of Notepad++ but it isn’t kept up-to-date like Notepad++.

MobaXTerm is a fantastic application that allows me to connect to the SSH/Telnet and more of any given server. It also allows me to browse the server through SFTP protocols all on the same window. I use it extensively to administer servers that I run both online and on my own network. I’ve also paid for the professional version, because of the amount of sessions I have. Can I do these things under Linux? Sure! Can I run this application natively under Linux? No. Which is a shame because I have many sessions saved in my MobaXTerm that I can’t transfer over, and it looks like I will need to manually set them up under new applications under Linux. There is software, apparently, that has similar functionality such as Ásbrú Connection Manager but I have not yet tried this out. Anyone out there that has any recommendations; please let me know.

Media Monkey is the application I use to manage all of my music, and it’s a lot. Apparently the application is compatible under WINE, but with mixed success. Allegedly they were going to make a cross-platform release for Media Monkey 5 where Linux - as well as MacOS - would be natively supported, but version 5 is out and this still hasn’t materialised (Yet). As a Licence Key Holder I would be very interested in getting this to work under Linux, as the choices as far as I can see pale in comparison to this application.

Stream Deck is an application I use to control my Elgato Stream Deck, unfortunately they don’t release a native Linux application. However there is something called streamdeck-ui or something of the sort that I might try out in another post. 

Corsair CUE controls the lighting on my keyboard and mouse. Given that I can save this stuff to the keyboard and mouse themselves and don’t require it, I’m not too cut up about this. It’s over a gigabyte big and doesn’t really do much anyway. I’ve tried OpenRGB in Windows, I’m not sure if it’s a thing for Linux, but it sucks, to be honest with you. Doesn’t even remotely have the functionality that iCUE does. So balls to that.

And there’s probably more that I haven’t considered yet. It doesn’t really matter. If it’s not native to Linux, there’s probably an application or package out there that is, that is somewhat similar. There might also be WINE and Play on Linux which I might play around with next time. 

Applications that do run under Linux

I don’t want to end this on a negative note, so I will say some applications that is natively supported on Linux, and run just fine for me.

Steam to some extent. This seems to work absolutely fine for me on Linux. I have no idea why, when it’s running in the background and not doing anything (Not even downloading) that it takes up 5%-7% of the CPU constantly. Taking a look at the processes, it seems the majority of it is “steamwebhelper” perhaps this is a bug with the application, or perhaps this is normal. I don’t know, but under Windows - this isn’t normal. It seems to have been reported back in 2019 but still exists. Other than this; does it work? Yes. Does it crash? No. Does it work as good as it does on Windows? Categorically - Yes.

KeePass well, to some degree. I am using the application that came from Discover called “KeePass Password Safe” and it seems to be true to the Windows Application. It’s not the best interface, it doesn’t seem to translate very well in Linux, but it works, and it does everything that the Windows one does, unlike KeePassXC, which almost looks like a totally different application entirely.

Browsers I have installed are Vivaldi, Chromium (Not to be confused with Google Chrome) and Firefox. It came with Konqueor. Vivaldi, Chromium and Firefox seem to work exactly like their counterparts on Windows. I could install Brave through Pacman, but I have chosen not to, and Google Chrome will not touch this installation of Linux for as long as I can help it. I’m trying to DeGoogle my life and as such everything that deals with Google will be done through the Chromium Browser. Vivaldi will most likely be my daily driver and Firefox - for other things. I may install Opera down the line too, but at this time I’m not too fussed by it. Yes; I don’t just use one browser. I use many and I compartmentalise the sites I go onto through the different browsers. 

Signal is an application that is very important to me. It can be installed on Discover but I think I either used pacman or downloaded it straight from their website, I can’t remember which. Either way, it works as good as it does in Windows and I haven’t had many problems with it what-so-ever.

EcchiDreams is a web based application that is important to me for obvious reasons. I was able to install this as an application and it runs absolutely fine on my computer. If I get an EcchiText, I get a notification that appears on my desktop and I can either click on it to see it and reply, or ignore it and continue doing what I’m doing with the hope that I will remember I had a notification later. (I never do. I always forget). I can run EcchiDreams in it’s own contained PWA container and do what I do.

Thunderbird is an application by Mozilla that allows me to download emails from all of my email accounts, accessible all in one handy application. I’ve been using Thunderbird since I was 14 years old (Late 2004/Early 2005) and it replaced Outlook Express that I had been using before it. Thunderbird has been part of my life for over half of my life, and I’ve never had a single problem with it. Importing my profiles from Windows to Linux after installation, and I’m happy to say that the legacy continues. The application works just as well as the Windows version and I have no complaints what-so-ever.

Private Internet Access is my VPN of choice. After a few little hiccups, this application does exactly what it is supposed to do, and runs just as well as the Windows version. I have no complaints here either.

I will wrap this post up here for now. Sorry for the wall of text. But there we go.

  • Love 2
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Read our Privacy Policy for more information.