Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Temaelrin

Shit I've bought from eBay... #5 - Synology DS212j NAS

Recommended Posts

Temaelrin

When is a NAS no longer just a NAS? 
Since Synology, apparently. 

large.IMG_2253.jpg

I remember when a NAS (Network Attached Storage) was just a NAS, and whilst I like the features ingrained in a Synology NAS sometimes for lower end NAS’s it’s a bit much even for it to handle and it drags the device down. Now before any fan boys start kicking off, hear me out. I don’t think this is a bad thing as such, at all. I see it as giving the user a choice as to what they want to use their NAS for, and the rest they have to decide on. If they have feature X; they can have feature Y and feature Z but it might choke on that. Unless they have a more higher-end NAS that can handle it. I am pro-choice in this regard (And no, that’s not a political statement). 

I used to have a Netgear Stora MS2110 which was slow, loud and frankly the worst NAS I ever owned. It had a read (download) rate of around 1.5MBps, and a write (upload) rate of around 750KBps. It had a loud fan and the hard drives in it echoed around the machine and you could really hear the clicking of the heads flying across the disk and all around crunching of the hard drive that hard drives made back then. 

@Manni introduced me to Synology though as a user, he was an administrator of a NAS and I had access via the web interface and it was the strangest thing I had ever seen. Eventually I went onto eBay and found that these NAS’s started at around £140 - £190 for the DS212j, at buy it now, although some started at £250. 

So a premium brand then?

I then found one on eBay starting at 0.99p and was currently at £17.52 with a few days left and decided ‘why the fuck not?’ and put my opening max price at £30, with plans to go up to £40 and have an upper limit of £50. I didn’t really matter too much though; because on the 25th of October I won it for £28.00. 

  • Item: Synology 212J 1 TB NAS
  • Price I paid: £28.00
  • Shipping: £7.50 (Courier) 
  • Total Cost: £35.50
  • Came With: Network Cable, Power Supply, Two HDD’s (500GB)

The package arrived on time, and it seemed to be extremely well packed wrapped in layers of bubble wrap. The first thing I did however was open it up (Of course!) and take a look inside, the hard drives in the unit came out, and I gave the machine a quick clean down and replaced the CMOS battery with a Kodak Button Cell 3V lithium battery. Taking the device apart was actually insanely easy, and this is the whole computer board:

large.IMG_2210.jpg

That’s pretty much it. There is a board that goes off and acts as the LEDs and power button as well as a board that extends the SATA ports for the hard drives, but this is pretty much the hub of the NAS right there. I am hoping that I can somewhat overclock the processor, or something or add a heat sink on it with adhesive thermal pads but I am not currently sure how feasible this is.

Initial Specs:

  • Marvell Kirkwood 88F6281 (Sheeva 88SV131 CPU core) (Feroceon 88FR131) @ 1.2GHz - Single Core
    • L1 Data cache = 16 KB.
    • L1 Instruction cache = 16 KB.
    • L2 cache = 256 KB. 
    • DDR SDRAM Controller
      • DDR2 400 MHz, Dual channel, 16-bit, 3.2 GB/s.
      • supports up to four DRAM banks (four DRAM chip selects).
      • supports all DDR2 devices with densities up to 2 Gb.
      • supports up to 32 open pages (page per bank). It supports DRAM bank interleaving, as well as open pages (up to eight pages per chip select).
      • Up to 2 GB total address space. DDR:CPU Clock ratio of 1:N and 2:N support.
      • support for 2T mode.
      • supports up to a 128-byte burst per single transaction from the Mbus port.
      • supports up to a 32-byte burst per single transaction from the Mbus-L port.
      • contains a transaction queue, read and write buffers. It can absorb up to 4 transactions of 128 byte each, in its buffers. Transactions from the Mbus are pushed into the transaction queue. The SDRAM controller arbitrates between the transaction from the top of the queue and transactions received from the CPU Mbus-L path, always giving priority to the CPU.
      • For a CPU read from the DRAM, read data is not pushed to the read buffer. It goes directly to the CPU bus interface unit via a 64-bit wide Mbus-L path. This minimizes read latency.
  • Cache: 256MB RAM
  • 1000Mbps Ethernet Connection

Hardware wise; there isn’t really all that much to show you, the motherboard of the device is shown above, this is the the SATA Bridge:

large.IMG_2224.jpg

Which I find absolutely interesting. The one towards the top of the picture (As the unit is upside down compared to the next image) is HDD Slot 2, where as the one on the bottom is HDD Slot 1. HDD Slot 1’s SATA connector looks very different to HDD Slot 2, noticeably the port between data and power. This is what I was talking about with the server hard drives in part 3 of my Shit I brought from eBay, the hard drives in that server will only fit into the HDD Slot 1, not HDD Slot 2, because of how the ports are made. They’re both as far as I can tell - SATA, except one seems to have a gap between the power and data where as the other has a stop bar that isolates the ports. I defined the difference as being SATA/SAS But who knows. I could be wrong. Please feel free to correct me in the comments below. 

This is what the NAS looks like with the hard drives in:-

large.IMG_2238.jpg

As you can see from the top screws, these are screws that I have replaced, they have rubber washers around them (As you can see in blue) this is what I put in to further reduce the vibrations caused by the hard drives (which translates as noise) by absorbing the shock of it. At least that was my theory. I have no idea how loud this was before this modification.

When I plugged it in and got it set up I learnt that there was an update for the device which I downloaded and installed… Immediately bricking my NAS. It wanted me to open the port forwarding on my router and contact Synology so they can access it and unbrick it. 

“Get fucked” I thought. Then I tried to do it myself… Telnet was disabled, SSH was disabled, and nothing was working. The device was completely inaccessible and refused to boot. I had a similar problem with the Netgear Stora once, and I remembered what I needed to do. 

I took the hard drives out, and decided to mount them as a RAID under a Linux Installation on my computer and scan them to see if they were properly formatted before I came to own them (They were! They had absolutely no data on them from the previous owner) and I wiped them clean with a binary zero write from the first sector to the last. Although I could have used Windows DiskPart to delete everything off of them, and clean the drives up. I put them both back into the device and used the Synology setup manager to restore DSM - and it worked!

Once it had installed, as I was only going to go around and test it, because the HDDs were going to get used in my Part 4 project (My IBM Server), I decided to play arounnd with the interface and settings and I did some file transfer tests. So during my test, with the Synology version of RAID enabled, I installed an anti-virus scanner because I figured that this thing is going to be connected to the network, it’d be good to have a layer of protection on there, and I didn’t think anything of it. 

So I went to test the transfer speeds and… Oh my.

The speeds were not very encouraging; as what I was seeing was zero bytes per second, that would occasionally jump to to several megabytes per second before crashing back down to zero bytes. After logging into the Web Panel I could see why. 

The CPU spikes up to 100% and the transfer crashes. When the CPU calms down the transfer goes back up and causes the CPU to spike up to 100% which crashes the speed of the transfer back down to zero again. Repeatedly. Whilst this is objectively better than my Netgear Stora, it still wasn’t good. 

So I did some research and put it off for a few weeks whilst I started writing up Part 1, 2, 3 and 4 of this miniseries. During part 4 I decided to move a 4TB HDD from my PC which had been previously acting up in my computer. But it was only going to serve the purpose as a backup drive in the NAS because after repeated hammering tests on the drive I cannot make the failure appear again and it seems to be otherwise fine. The NAS will serve the purpose as a backup drive, to back up data from the local network. 

So let's now talk about DSM, specifically DSM 6.2:

large.webinterface0.jpg

When you go to the location that the NAS is installed on (as a website address) you’re presented with a login screen (That can actually customise and change to some degree) like you can see above. Once you’re logged in you’re then presented with a desktop environment essentially:

large.webinterface1.jpg

From here you can pretty much set up the rest of the device and how it sits on your Network, as well as set up user accounts and install features on your NAS. 

So let's take a look at the control panel: 

large.webinterface2.jpg

In here you have several options as you can see above that has own tree of sub menus and sub options you can look at although I won’t be putting the screenshots of which into this document.

The first item “Shared Folder” which allows you to create root(ish) level directories when viewing the NAS through the Windows Networking Explorer for the NAS. These can be locked to different permissions so if you want a folder that only user 1 can see, and not user 2, you can indeed set that up, or if you want it so that user 2 only has read access - this again is possible. I kept mine to just one; as it allowed me to easily mount it as one drive (Via Map Network Drives) under Windows:

large_PC.jpg

Which allows me easy access to the NAS. 

The Shared Folder setting also lets you control encryption of the folder, although I haven’t used it. I don’t think the CPU can handle it (And I will explain why in a moment). 

In the “File Services” page you can set up the following:

  • SMB/AFP/NFS
  • FTP/SFTP
  • TFTP
  • Rsync
  • Bonjour
  • SSDP
  • WS-Discovery

The only services I have enabled here is SMB (Samba) and SSDP (Simple Service Discovery Protocol) which allows my device to be detectable under the Windows Network, but also locks it down from being accessed from the outside, which is a layer of protection under the NAT on the router to prevent outside access to the NAS. But you can set it up so you can access your NAS from the internet - which means you can access for files anywhere. But in my opinion you’re opening yourself up to some trouble. 

Consider this: You can already find Synology NAS’s that are open online merely by searching Google for it (I’m not going to give the key phrase here) but I have done it, and I can confirm you can do it. This isn’t necessarily a bad thing, but you’re broadcasting at that point to the internet that your NAS exists and it’s there. Things have already hit NAS’s that effectively take them and the data that they hold to ransom - just look at SynoLocker. By advertising your NAS on your IP address this is what you’re opening yourself up for. A dedicated hacker who wants access to NAS’s will eventually get in. And everything you store on it can be exposed. 

So for me; I have it set to network access only; no internet. I have a private web server set up elsewhere for files I want to share with myself when I’m away from home. Something that is set up, designed and locked down to serve this purpose, which requires specific PGP Keys. It has no domain name, and doesn’t appear on any searches, not am I hosting it here at home. I won’t say what other security features I have with it, but I will say that It’s not perfect, and it can be a pain in the arse sometimes so… and it probably isn’t for everyone. 

The next is “User” and this is self explanatory. This is where you set up users and their permissions to the NAS, such as what apps they can use, what folders they have access to and so on. The next on the list “Group” is very much so apart of the users setting I think its you create default group permissions. 

The next setting, I assume is for advanced users because it’s the “Domain/LDAP” setting which is probably good if you have a Windows Server with a Windows Domain on it. I don’t use either of these so I’m afraid I can’t tell you what exactly it does. 

Under Connectivity you have a setting called “QuickConnect” which is the Synology QuickConnect feature that allows your NAS to be accessed from anywhere (As long as you have an internet connection) I quite obviously have this disabled, and it requires a synology account. You get given a quick connect ID which will allow people to access the NAS without the need to give out your IP Address, and the next setting “External Access” with DDNS and router configuration is keyed into that. Again - I don’t connect externally, nor can my NAS be connected from outside the Local Area Network. My guess is, is that you can set up your custom domain here, instead of xxx.xxx.xxx.xxx (Where ‘xxx’ is a number between 0 - 255), you can connect via a domain name like ‘www.domain.tld’. So this doesn’t apply to my use case. 

The next setting is ‘Network’ and this was quite important to me. In here you can set up what the server name is, where the default gateway is connected to (In my case, my router), if there is a proxy server in the way, and what it’s configuration is, the network interface, traffic control restrictions, static routes as well as the DSM settings. The DSM settings allow you to control what ports you can access your NAS on (Which I have changed from the default), whether or not you want them to be automatically redirected from HTTP to HTTPS (Which I recommend, especially if you’re accessing it externally), enable HTTP/2 and edit your own Server Header. You can also enable HSTS but if I recall correctly for enabling it on EcchiDreams - you *need* a domain name, and a valid certificate. 

The next setting is ‘DHCP Server’ which on the large part - I don’t need. Because my router is my DHCP server. But… If you wanted to, you could also enable PXE (Pre-boot Execution Environment) from here too, which some computers/servers are compatible with, which is pretty much used in Enterprise environments. It essentially allows you to boot and install a computer from a central location - might not be worth it for one or two computers. But for tens or hundreds, thousands or more computers on the same network - then it’s perhaps worth it. Trip down memory lane in spoiler: 

Spoiler

 

I remember in my secondary school, all the computers in the school booted from the network on Windows XP, which included the authorised applications and such that came with the payload (and took absolutely FOREVER to boot up). You couldn’t make meaningful changes to the OS and you had to store your files on a custom network drive that contained your personal files. There are upsides and downsides to this; you can apply security updates and such and it will affect every computer on the network. But this has backfired before, even at at school, when there was a bad update for Windows XP and the IT technician spent the better half of a week trying to restore from backups. If the image goes down it all goes down. And I also had a little part in playing around with the security of it… After school (Because we had Late Buses, that would take us home from school after ours) I sat down with the IT technician, let's call him John Smith. And I showed him how I could exploit the software from the user end that was running it (I can’t remember the name of it; but it was made by RM) to give myself Administrator privileges over the network, something he couldn’t believe that I could do, and he was able to see how I did it and stop the exploit. (I of course did it under his supervision, with his permission, and everything). I could even set up how much storage I could have (Increased it from 250MB to 5GB) as well as see what other users were doing via some kind of screen monitoring, and control the web filter. Furthermore a few months later I was able to exploit it using a different exploit and set up a game which I hid in the OS drive (I think it was a Pinball game), which I reported and showed John Smith exactly how I did it and why. This took a little longer to patch because it was a security exploit with the RM software itself. He asked me nicely to not abuse it or tell others, and I didn’t.

However during some point I moved, and went to a different secondary school that had all the same exploits and worse. The IT techninition here (Lets call him Joe) was not as friendly and when I tried to alert him of these exploits instead of fixing them, he shouted at me, and limited my access. Not a good move because I was going into a period of my life where I was rebellious to say the very least, and the next day he lost Admin access and I became the admin of the school network. For a day… I also installed games on it so everyone had access to games, and so on. 

Same thing in College; except this was in a certain room where all the computers were networked together in that room. Isolated from the rest of the college, it didn’t even have internet access, and files had to be saved on an external flash drive. This time, @SMFoxy (Whom I went to College with) and I discovered ‘Call of Duty’ (The first one) as well as a Medal of Honour, installed on the computers, but it was hidden, not obvious. We told the rest of the class and people were playing in Single Player for a while. I think the room was the networking room, so it was intended to be there, it was supposed to be a challenge at the end of the year to set up the network and play Call of Duty as a class. But Foxy and I found it pretty easy, and then we were able to configure the IP networks of everyone's computers in the classroom, and within a month of starting at 1 to 2 hours a week in that specific class room we were all playing Call of Duty… Until the teacher cut the network switch so we were all isolated again… But that didn’t stop us from playing around with it- or from me bringing in a patched LAN cable and playing with someone else in a private game. Another game that got installed by a classmate was a text based RPG called ‘Drug Lord 2’, I got my hands on this and made it available to the whole room. 

So in short PXE - Only if you know what you’re doing. 

 

The next setting is ‘Wireless’ which, if you connect a WiFi adapter to the NAS (By USB) you can have the NAS connected via WiFi. It seems to be able to support three modes; Wireless AP, Wireless Router and to join a Wireless network. In this setting you can also set up Bluetooth, with the correct adapter. I have mine connected via Ethernet port so this isn’t applicable to me. 

The next setting is ‘Security’ which allows you to set up the security of the NAS. Such as an automatic logout timer, cross-site request forgery protection, CSP headers in the HTTP content security policy, allowing or disallowing the DSM to be embedded in an iFrame, and so on. It also has a built in firewall which you can control, DoS (Denial of Service) protection, login protections (Such as get a password wrong 3 times in 10 minutes and the NAS locks your IP out), SSL Certificate storage, HTTP compression and TLS/SSL profile levels, which I recommend “Modern Compatibility”, to get the best level of protection. 

The next setting section is ‘System’ and under this at the top is “Info Center”:

large.webinterface3.jpg

Which is the hub of information about the NAS itself; the General Information tab which as you can see displays the status of the NAS. The Network tab shows the information pertaining to the network setup. The storage tab shows the information on the hard drive, such as size, free space, how much data is on it, what RAID format it’s in (In my case SHR), the model, temperature, location in the drive bay and whether or not it’s operating normally or malfunctioning. The next tab - Service, shows what services are enabled on the NAS and allows you to manually enable/disable them and allows you to test the connection. The next tab is device analytics which is data sent back to Synology on how you use your NAS. I’ve obviously disabled this because frankly it’s none of their business. The last tab here is for you to connect your Synology account to the NAS - which I don’t have one, nor will I ever get one.

The next setting is the theme setting:

large.webinterface4.jpg

This is where you can control the look of both the login screen via the “Login Style” and the general theme of the device via “Theme” although you can only seem to select light or dark. The login screen lets you put in your own pictures as a background which is pretty nice, and allows you to put in your own logo, which I have used the EcchiDreams information and logo to demonstrate for this write up. 

The next setting is “Regional Options” or perhaps better known as Localisation. This allows you to control the timezone, and time settings as well as update your NAS to automatically synchronise the time with an NTP server. The next tab language is self explanatory it lets you set the default languages of the NAS, it’s notifications and codepage. Then of course you have an NTP Service which allows you to set up the NAS as an NTP Server (To syncronise time across devices attached to the network), the problem is though, most modern OS’s have this built in like Windows 10. 

 “Notifications” setting, in a nutshell lets you control how it sends notifications to you. It can do so via email, SMS or push service. With email it has a built in Google connect like interface that allows you to hook up a Gmail Account, Yahoo, Outlook, QQ or your own SMTP server to it; and it’ll send off email notifications automatically, including any welcome emails to new users. With SMS, you pretty much have a choice of ClickaTel, ClickaTel-2017 and Sendinblue-v3 all of which I do not use. With the push notifications you can use a Synology email server you download an app to your smartphone (Apple/Android) and pair your device with that. As seen with the mobile phone screenshot.  

large.5004855964878440292.jpg

Not only can you receive notifications from this app, but you can actually pretty much control the device with an administrator control panel if you have the right privileges. It’s a pretty handy app to have, and I’ve not yet experienced problems with it. Under the advanced tab, like with EcchiDreams, you can select what notifications you get, and how you get them, like by push, SMS or email.  So all in all pretty good.
Then there’s the ‘Task Scheduler’ setting that allows you to set automatic tasks that the NAS performs, such as DSM Auto Update and S.M.A.R.T Tests on the Hard Drives. It’s pretty simple. You can select how often these tasks run, or if they run at all. 

Next you have ‘Hardware & Power’ which is interesting, and I’m going to go through this one by starting with a screenshot. 

large.webinterface5.jpg

This has some handy little features that really put you in control over your own NAS. Much needed, especially after my Netgear Stora. Specifically the Fan Speed Mode. I have it set to quiet, because the current max temperature the hard drive gets to in the device is around 37oC - 40oC. Which is within tolerance. But then again it’s one hard drive. But I have to say that even on Full-Speed mode, the system is impressively quiet, although I am still considering on switching it to Low-power mode. Which completely stops the fan when it’s cool. In this menu is a power schedule that will allow you to have the NAS on at certain times of the day and off at others. HDD Hibernation allows you to power down the hard drive to minimise power consumption which I do (After 20 minutes), and further reduces noise when the system isn’t in use. This is something that if memory serves me right - existed on the Netgear Stora, but when it booted back up - my goodness it was loud. Then of course you have UPS which allows you to connect the NAS to an uninterruptible power supply. Seems like more of a server than a NAS, and I will get to that. 

In the External Devices settings you can pretty much set up USB External HDD’s, Flash Drives and printers. I have tested this feature and it seems to work nicely with my flash drive. But I don’t use it. 

‘Update & Restore’ is next. This is basically for DSM (Disk Station Manager) to make sure that the Operating System of the unit is up-to-date and so on. It also lets you configure backups as well as reset the NAS and restore it to factory defaults. But that said, I’d advise caution against the resetting feature. It seems that every time I’ve used it, I’ve needed to take the hard drives out to completely clean them under Windows using Diskpart to delete the volumes, partitions and then clean the disk… Because it bricks the NAS… Completely.

‘Privileges’ seems totally pointless to me, it’s to setup features enabled on a user/user group level which is already available in the User and Usergroup settings. 

‘Application Portal’ is something I’ve not used. Nor do I really know what it really is. The help file says “Application Portal allows you to configure the connection settings of various applications so that you can directly access and run these applications (e.g. File Station) in independent browser tabs or windows.” However there’s a problem with this - that as I have said I will get to. Because you can’t enable too many features on this NAS. 

‘Indexing Service’ or ‘Media Indexing’, pretty much just scans for multimedia files automatically such as photos, music, videos stored on the NAS. It also lets you control what kind of quality you want thumbnails to be in and enable video compression for mobile devices. You know that problem I mentioned in the previous paragraph- yes. I will get to that in a moment. It even warns you as a hint here “Note: Enabling this option will take more time and CPU resources.” The idea is to compress it, and I assume Transcode it for lower end Mobile Devices. 

The next setting is ‘Shared Folder Sync’ which requires me to use RSync, which I don’t. I assume it lets you sync multiple NAS’s together. I only have one, so I don’t use it. 

‘Terminal & SNMP’ Setting is the last setting in the control panel and this is something I will not use, nor leave open. The Terminal is basically Telnet/SSH which allows for command line access to the NAS, I have tested it and it is basically a Linux server. I see no need to enable it at this time. As for SNMP, if I recall correctly is some kind of Simple Network Management Protocol which I do not need to enable on my NAS. 

And that’s it for the settings. The next thing you might have noticed in all of the screenshots is the ‘Package Center’ this is where you go to install new software features on the NAS… And we’re drawing near to my problem with this device that I have said repeatedly “I will bring up later.” 

large.webinterface6.jpg

Just look at all these additional features… It’s… Well, it’s a lot. 

One has to ask: How often are these applications - especially by third parties, updated? Because the MediaWiki app is version 1.30.0 which is out of date, there is 1.30.1 and even 1.31.1 which are both security updates. To make matters worse; Apache HTTP Server 2.4 is version 2.4.29-0011… The latest is 2.4.37 which I am pretty sure that between .29 and .37 there are a number of security updates as well as bug fixes. I wouldn’t consider this secure, especially if you’re hosting a website on that has access to the internet. Node.js only seems to go upto 0.10; the version now is 11.3.0, with security fixes released just a few months ago. 

Same things with:

  • phpBB, what you get on the NAS is 3.2.1 (July 2017). Current Version is 3.2.4 which was a security fix. 
  • WordPress, what you get on the NAS is 4.9.7. Current Version is 5.0.
  • Python3, what you get on the NAS is 3.5.1 (2015). The Current Version is 3.7.1. 
  • Drupal8, what you get on the NAS is 8.4.8. The current version is 8.6.3.
  • Ruby, is the most egregious of the lot that I found. On the NAS: 2.4.3… Latest version: 2.5.3, with tonnes of security fixes and patches. 

So when is a NAS, no longer just a NAS? Since Synology apparently… In this day in age we need to keep things updated and this NAS has all the features of a web server, it lets you even make on… But you can’t keep it up-to-date and in my opinion this is not ideal to say the least. Now some of these - maybe no problem. Sure. But some of them are missing critical security fixes and are severely flawed. Control has to fall with the user, and if Synology insists on making it easier for the user then Synology has to update the software, or have the NAS download the latest version of the software. 

I would not recommend using any of this, personally. 

Don’t get me wrong - this is hands down the best NAS I have ever owned and it’s a low end model. I love it. But come on. I have to be critical here, and some of these might open pandora’s box of security holes, exploits and bugs that could run the NAS into the digital ground. 

But the temptation - and this is where my problem comes in, is to start enabling all of the features willy nilly. But the problem is… Just loading this screen, this package centre takes about ten seconds at full CPU usage, and if it does that just loading up the screen then how can it run any of these things? Certainly at the same time as you’re trying to use it as a NAS… It’s going to choke. 

Even with just the Anti-Virus scanner enabled; the system was unable to maintain good read/write speeds, constantly breaching 100% CPU usage, and holding up the upload/download, until it went down again, and even then the web interface freezes up repeatedly whilst 1 person is transfering files to and from the NAS… I’m sorry but to ask it to do more than one of these things in addition to being a NAS is simply not going to be as responsive and the more you install the worse it will get. 

But maybe it’s not a problem if you’re going to say - use the NAS as a mini-web server instead, with Apache, PHP, PHPMyAdmin and MariaDB. But there are several problems here too, the complexity of the web application you want to use will pretty much be your limiting factor. Installing and running something like IPS (The Forum Software we use) might not be feasible, or quick and responsive at all, and may even require modifications that you cannot make such as installing additional PHP Extensions like GD2 extension or the mbstring extension. 

That tiny 1.2GHz Processor doesn’t even have a heat sink, it’s passively cooled so I don’t know what kind of power people expect to really get out of it. As I said I couldn’t browse the web interface with ease when someone was using the NAS and that was just one person transferring files to the NAS. So I have no idea how it’s going to handle transcoding video to one device let alone several, or how you can really enable any of these features if multiple users, use the device. 

Maybe with a more powerful NAS you can run these features side by side, I don’t know. But with the DS212j… I really wouldn’t recommend that if you want advanced features. 

As for transfer speeds with barebones - no extra features:-

Download from the NAS:

large.download.jpg

Upload to the NAS:

large.upload.jpg

It’s certainly better than 1.5MB/s download and around 750KB/s upload. So I am happy about that. I have been able to download on some occasions at around 50-100MB/s which is amazing. But these are far and few between. I spent £35.50 on it second hand, and it works. Do I really have a right to complain at all? ... Probably not.

Next on: "Shit I've bought from eBay" - HP MS228UK AiO Desktop PC

  • Like 1
  • Love 1

Share this post


Link to post
Share on other sites
Whoreo

I would be very interested to know if you still use this, and if so what for? I was looking at getting one so that @Jordii~kins and I can sync our music together and listen to it on any device in the house... would this do it?

  • Like 1

Share this post


Link to post
Share on other sites
Temaelrin

We still do use it yes, although I might be looking at getting a HP Microsever at some point to either go with it, or replace it, as I can custom load Synology firmware on it which might help if it has collaborative document editing services enabled on it much like Google Docs - as I am still trying to come away from Google and reduce it's tentacles into my life. 

Will this serve music and allow you to back it up in a central location in your house? Yes - very easily. I recommend using the Ethernet connection though. I think if that's all you're using it for, between two people - then this device will more than happily serve your needs. Neptune and I use ours for this exact purpose and we are quite FLAC heavy (Which is like an MP3 but around 10x bigger), and we can both listen to music from it with no stuttering. 

I'd recommend this for that purpose. 🙂

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 Dreamers

    No registered users viewing this page.

  • Similar Content

    • Temaelrin
      By Temaelrin
      What do you call a computer strapped to the back of a monitor?
      Apparently it’s a AiO computer… 😕

      I found this strange little thing on bid for £4.99, and there really wasn’t all that was said about it. No specs, no model number, nothing. Just “It turns on” but “It has a password” therefore it was being sold for spares and repairs. 
      A BIOS password is extremely easy to bypass; usually it’s just a matter of moving a jumper and turning the computer on, or just taking out the CMOS button cell battery (Usually a CR2032). 
      I figured at £4.99 (Plus £9.99 shipping) there really wasn’t much to lose, and took the plunge, putting in a bid for it. My max bid was £20; I wasn’t really willing to spend more than £29.99 on it, because it was a curiosity more than anything, and I had no idea what the specs were, at all. I was surprised that no one else was interested in it. He claimed he had brought a load of them from a joblot and was selling them individually on eBay. It was advertised as coming with the power cables and VGA cable, but other than that; there wasn’t much.
      Of course after I bought it, the seller started charging £14.99 for them +£9.99 Shipping. 
      Item: Ex-School AiO PC (Parts and Spares)
      Price I paid: £4.99 Shipping: £9.99 (Courier)  Total Cost: £14.98  Came With: A heavily modified Windows 7 Installation.  This topic won’t be as long as the others because there’s not really much to talk about. 
      When I got it, I was impressed with the condition of the machine; I have to admit I had reservations about the overall build quality, especially when one of the CEO’s for Viglen back in the day was Bordan Tkachuk who is perhaps famous/infamous for saying:
      He’s completely wrong, of course, in more ways than one. So I wasn’t inspired to say the very least, as the man seems to know nothing about basic knowledge for people who are supposed to be working in Technology.
      Anyway, the condition of the machine was pretty good, and when I booted it up there was indeed a BIOS Password. Removing this was a simple matter of opening the case and flipping the jumper which was readily accessible. When I turned on the PC it told me that the password had been cleared and that I needed to reboot the machine with the jumper in the correct position. 
      I did that, and I was presented with not Windows Vista (Which is what I was sold) but Windows 7 (Enterprise, I think) and it was very heavily modified. It seemed to have come from a primary school, and thus it was expecting a domain server on the network that it couldn’t find. 
      I’ve spoken about this before in regards to school computers and servers. Quite often there are no sensitive files on these machines because the files aren’t stored on them. Instead they’re stored on a kind of ‘Profile’ on the server that allows you to log into any authorised computer on that network, and have your files/documents travel with you when you log onto that computer. This is because the files aren’t stored on the actual computer - it’s just a workstation. The files are stored on the actual server. So there wasn’t any sensitive files on this device - I knew this before I hacked my way into the OS.
      Once I was in the OS (Using a backdoor user account that was created on the machine probably during setup) I confirmed that there was nothing groundbreaking left behind. Not a single document, or text file, incriminating evidence, family pictures or otherwise. I ended up wiping the hard drive and put Windows 10 on it - although I some issues after I opened it up again and took it apart. Which I will get to in a moment. I had rolledl back to Windows 7 whilst I was sorting these issues out, but eventually I diagnosed the fault and put Windows 10 back on it. 
      And it works perfectly.
      Before I get into it this time; let's find out what I bought: 
      Viglen Genie AiO PC (With Intel DQ35JO Motherboard)
      CPU: Intel Core 2 Duo (E8400) LGA775, 45nm Chip Dual Core @ 3.00GHz L1 Cache 2 x 32 KB instruction caches  2 x 32 KB data caches L2 Cache 6MB (3MB per Core) 4 KB Pages, 4-way set associative, 128 entries 4 MB Pages, 4-way set associative, 32 entries 52.81W Typical Power Consumption (65W TDP) 4GB Max Supportable RAM Chipset: Intel(R) Q35 Express Chipset Family (North Bridge: Intel Bearlake Q35) (South Bridge: Intel 82801IO ICH9DO) RAM: 4GB DDR2 (4 x 1GB) 2x Samsung M3 (1GB Each) Non-ECC RAM Bandwidth: PC-5300 (667 MHz, DDR2) Timings: @ 333 MHz 5-5-5-15 (CL-RCD-RP-RAS) / 20-43-3-5-3-3 (RC-RFC-RRD-WR-WTR-RTP)  @ 266 MHz 4-4-4-12 (CL-RCD-RP-RAS) / 16-34-2-4-2-2 (RC-RFC-RRD-WR-WTR-RTP)  @ 200 MHz 3-3-3-9 (CL-RCD-RP-RAS) / 12-26-2-3-2-2 (RC-RFC-RRD-WR-WTR-RTP) Model: M3 78T2863QZS-CE6 2x Kingston (1GB Each) Non-ECC RAM Bandwidth: PC2-5300 (667 MHz, DDR2) Timings: @ 400 MHz 6-6-6-18 (CL-RCD-RP-RAS) / 24-51-3-6-3-3 (RC-RFC-RRD-WR-WTR-RTP)  @ 333 MHz 5-5-5-15 (CL-RCD-RP-RAS) / 20-43-3-5-3-3 (RC-RFC-RRD-WR-WTR-RTP)  @ 266 MHz 4-4-4-12 (CL-RCD-RP-RAS) / 16-34-2-4-2-2 (RC-RFC-RRD-WR-WTR-RTP) Model: Unknown Optical Media: Optiarc DVD RW AD-7633A SCSI CdRom Device Firmware: 1.00 Can read: CD-ROM CD-R CD-RW DVD-ROM DVD-R DVD-RW DVD+R DVD+RW DVD-RAM DVD+R DL DVD+R9 DL Can Write: CD-R CD-RW DVD-R DVD-RW DVD+R DVD+RW DVD-RAM DVD+R DL DVD+R9 DL Network Cards:  Intel(R) 82566DM-2 Gigabit Network Connection (1000M) Graphics: Intel GMA 3100 (Integrated) on the Intel(R) Q35 Express Chipset. VGA Output DVI Output Upto 256MB shared memory PSU: 1 x Enhance 250W Power Supply (80 Plus Bronze Efficiency Sticker)  Model ENP-7025C HDD: 1 x 80GB (Originally: WDC WD800AAJS-00WAA0, 80GB, 7200 RPM, SATA II) Monitor: A 4:3/5:4 Ratio Maxdata Belinea 17” Display with USB Passthrough and built in speakers (They’re awful).  Sound: Realtek High Definition Audio (Realtek ALC268) Stereo Speakers Integrated with Monitor (I don’t know the wattage, they’re absolutely atrocious though).  For £4.99 ($6.30 USD, $9.09 AUD, €5.57 EUR, $8.35 CAD, at the time of writing) the specs are really not bad at all! I could easily flip the computer on it’s own for quadruple the price, which makes back the shipping and I get a free monitor for my troubles. It could make a fantastic computer for a child who uses it for homework and basic word processing, as well as light internet usage. 
      I think it’s got reasonably competent connectability; a gigabit ethernet port is a major plus with this machine, which is on the back with a firewire port, six USB2 ports a VGA and DVI port as well as microphone, headphones/speakers and a lineout port. On the front it has two USB2 ports, a headphone jack and a microphone jack.
      However; as I expected with Viglen - which might as well mean buy the cheapest possible components and throw it all into a computer case to see if it sticks - the internal engineering is absolutely abysmal. At 5.1KG for the computer unit alone, (5164g) this is not a lightweight. Cable management was an absolute nightmare and no thought was put in to the case either. 
      Take a look at the inside:
      This is after I cable managed it. 
      The major problem with this machine is heat, and on that note I’d love to meet the absolute spanner who thought it was a good idea to put a PSU directly above in near contact to the Intel 82801IDO Southbridge heatsink! It gets to temperatures in the region of 92oC hot and it cannot dissipate the heat properly because there’s no airflow over that area, and to top it all off the PSU is generating a generous amount of heat as well. In addition; the HDD is right on top of the RAM (Also generating a good amount of heat). The Power distribution of the system seems precarious at best. 
      The thermal paste was god awful and was causing several Thermal Cutoffs (Where the machine would outright shut down to protect the CPU), not allowing me to do an accurate test of the CPU temp before thermal pasting. But in fairness most OEM’s have poor quality thermal pastes. I replaced it with my standard Arctic Silver 5, but under the current configuration it’s temperature is erratic under load: 
      But at least it’s not cutting off outright. 
      This is this machine’s biggest enemy, and I think I might know of a few solutions to help with it. The CPU fan seems to be an intake, where as the PSU fan and the one opposite are output fans. 
      Picture I took whilst I was dismantling it to replace the Thermal Paste:

      After stabilising the machine, I did some cable management and tied it up. I did try replacing the HDD with a higher capacity one, however I had lots of errors happen when I did that, such as “Memory_Management”, and so on until the computer just outright failed to detect any other hard drive other than the 80GB one. You’d hear it power up, and then it’d power it down repeatedly - and this was with a good hard drive (Because I use it in the HP AiO now and it’s absolutely fine) This is why I suggest that the power distribution is precarious… Perhaps and SSD will do fine in this system - were it not for the heat issues I’m finding. I do not like subjecting SSD’s to more than 35oC of heat, certainly no more than 45oC if I can help it. 
      That said. Despite the system running much hotter than I’d personally care for, it does run now, and I’ve not had a problem with it. But perhaps I will run it in the winter when I don’t want to use the heater in the house. 
      I believe this motherboard could be translated to a different case and utilised to its fullest extent. With a decent cooler on the CPU there is plenty of upgradability here; especially with those SATA ports (Red one is designed for External SATA).
      There’s not really that much more to say about this machine, it was extremely cheap and you get what you pay for, however individually, the parts are worth more to me than the whole machine. Why I can use the RAM with another old machine I have, and the CPU with the next item I will be featuring. If you do have any questions please leave them below!
      I’ll close with some AIDA64 Benchmarks, but I will be comparing them to my next ‘Shit I’ve Bought on eBay’ as the next machine is comparable as it has the same CPU:
      RAM:
      Memory Read: 7,098 MB/s
      Memory Write: 6,955 MB/s
      Memory Copy: 6,384 MB/s
      Memory Latency: 100.0 ns
      Central Processing Unit Benchmarks:
      CPU Queen Score: 12,662
      CPU PhotoWorxx Score: 3,498 MPixel/s
      CPU ZLib Score: 75.3 MB/s
      CPU AES Score: 328 MB/s
      CPU Hash Score: 959 MB/s
      Floating Point Unit Benchmarks:
      FPU VP8 Score: 2,102 
      FPU Julia Score: 4,056
      FPU Mandel Score: 2,144
      FPU SinJulia Score: 1,099
      SIMD-Enhanced Ray Tracing Benchmarks:
      FP32 Ray-Trace: 582 KRay/s
      FP64 Ray-Trace: 305 KRay/s 
      Next on: "Shit I've bought from eBay" - ACER Veriton L670G PC
    • Temaelrin
      By Temaelrin
      What happens if you cross a netbook with a Desktop PC?
      Well, meet this cute little fellow.

      This little computer has a width of 25CM (9.84 inches), a length of 20.5CM (8.07 inches) and a height of 6CM (2.36 inches) making it one of the smallest desktop computers I have ever owned. 

      It is so small in fact that it almost doesn’t even look too out of place on my bookcase, and is smaller than my A4 folders, and the Star Trek: The Next Generation Technical Manual too, as you can see here:

      So for this one; I was just browsing around on eBay (As I do from time to time) and I noticed this for £10.00; plus free shipping. At the time on the 4th of April there was no bids on it, and I decided to keep a watchful eye over it. I put a bid on it for £20 with my ultimate max going to be around the £25 range. 
      A few days went by - nothing. But on the last day it there was an explosion of bids that stopped about an hour before the end of the bid, with the bid sitting at £15.00. But then on the final minute; I raised my max bid to £25, and it was just as well because on the final few seconds someone attempted to bid snipe me to knock my previous maximum out. In the end I won it for just £20, bid sniper BTFO’d. 
      The same seller has these computers selling comfortably for £35-£50, buy it now. So I think I got a hell of a good deal; especially when you consider that the DDR2 RAM and the HDD alone would sell for way more than that on eBay; this was a pretty good deal. Did I need this computer though? No. I just wanted it.
      Item: ACER Veriton L670G Core2Duo E8400 2 x 3.00GHz 4GB 320GB DVD PC Computer
      Price I paid: £20.00
      Shipping: Free (Courier) 
      Total Cost: £20.00
      Came With: Power Supply.
      Honestly you’d be surprised with the cheap computers you can pick up on eBay. When I was handed this box at the door, I was concerned that it looked a little too small. The eBay photograph didn’t quite prepare me for how small this machine really was; where as you were prepared before getting to this point in the topic. I thought it was going to be a normal ATX-Form Factor Desktop PC, that didn’t really have much to write home about. 
      Manufactured on October 23rd 2010, this small machine actually packs one hell of a punch. Whilst I have no doubt that this will not run any games (As in it most likely won’t) it’s quite the responsive little computer. When I opened up the box and started taking out the packaging paper, I found the PSU which is pretty beefy. 
      Under this more packaging paper, and then the computer itself… My first words about it was “Aww; this is cute. It’s a Neppy Computer.” Which got Neptune’s attention; as when I usually prefix something with Neppy, I’m meaning it’s small. Kind of like “Neppy-Sized” = “Fun-Sized”, which is a bit of an in-joke between Neptune and myself, because standing next to me she is quite ‘Small’. Neppy sized. 
      I pulled out the computer and even she remarked “It’s dinky.” My first port of call - as always - was to open this little bad boy up and see what was inside, and to take out the hard drive and put it into my desktop’s hotswap bay and find out what kind of condition it’s in, and if there is any recoverable information on it. 
      When I opened up the small computer I found it to be absolutely caked in this extremely fine dust. And I mean it was extremely fine, almost like carbon from a 90’s printer toner. So it needed to be stripped down and completely cleaned out, but I held off from that, and only cleaned out the bare minimum. I put the hard drive into my computer and ran crystal disk info which got me this information:

      Which is not bad; it tells me that the hard drive has only been spinning for 189 or so days - and should have plenty of life left in it. I have hard drives in my computer that have been running for double that or more, with one running for over 918 days. It also had no problems, and seemed absolutely fine. I then also tried to do a data recovery on it. 
      … There wasn’t a single bit of information. 🥳 It was completely empty, and properly wiped! So thumbs up for that. 👍
      Who ever had this last wiped it very well; even if it was zero filled and I’m extremely impressed by this. This is exactly what should be done when you sell your computers and/or hard drives on eBay. The seller made no indication that they had wiped, or formatted the HDD. Usually when they say they ‘Wiped’ the hard drives they just quick format it which is not good enough as the data can still be recovered. But this hard drive didn’t even have partition information on it. It was completely blank. That tells me that someone has their head screwed on.
      I noticed that there was a Windows 7 Pro Certificate of Authenticity sticker stuck to the bottom of the computer as well as several other stickers. However I have a few retail licences for Windows 10 Pro kicking around, so I put Windows 10 on it, and ran my stress tests to get a baseline for the computer’s temperature. Then I pulled the whole thing apart and cleaned it all out, fans, heatsinks, the shitty Acer thermal paste that had turned to cement, and so on. 
      The temperatures have only improved by about five degrees centigrade, which means to me anyway; that the system wasn’t struggling to stay cool, which is astonishing to me. I lost the before chart; but this is the result after it was done:

      No thermal throttling and the CPU Temperature a good 30-40oC away from maximum temperature, and indeed the air coming out of the back is pretty cool, I think. Certainly much cooler than the Viglen AiO PC. For reference here is the Viglen graph:

      Taking a look at under the hood, and it’s pretty clear to see why the Acer succeeds in cooling; 

      This should give you some idea about the size and scope of this machine. Unlike the Viglen AiO, this uses notebook RAM.
      The left and right hand sides are vents that allow the system to draw in cool air, there’s a massive heatsink attached to a heavy block at the back with two small fans side by side sucking air out of the machine. The design of this is exceptional (Especially coming from Acer) because it means it’s pulling cool air in through the hard drive which goes through that heatsink next to it (Covering, I think either the GPU or the south bridge, I don’t recall) combined with air coming in directly next to it before being sucked through the heatsink of the CPU, through the block at the back and out of the system. The air that comes out is not too hot, but it is warm, and the system stays at a cool temperature throughout. 
      Now, on the underside of the machine; is where I made a rather neat little discovery… I’m writing this document for my post as I am testing this part out, so we’ll see how it goes.

      This is a Mini PCI-E slot, now this is where my knowledge on hardware hits a brick wall - because I’ve very rarely played around with Mini PCI Express slots and the things that can be used by them. From what I do know; this is where I could fit a wireless card in. But...
      I’m not sure if it would work or not (The pin count seems to be about the same) I could theoretically fit Mini PCI-E SSD which I’ve seen on sites like NewEgg and eBay, which I can use as the boot drive, and the 320GB drive as a data storage drive, or swap disk for the Windows Page File, or even a scratch file for Photoshop. I’d enjoy an even more snappier experience. But I don’t know if that’s possible or not. If anyone here knows, let me know, and if anyone wants me to post my findings on this when I do go and explore it, then please let me know. 
      For all I know it could be there but completely disabled in the BIOS. I do have a spare Wireless Mini PCI-E card kicking around so I suppose my first port of call would be to test this using this card… Which is exactly what I will do; if I ever find it, before I invest into looking at utilising it. 
      The Specs - 
      Acer Veriton L670G (With Acer EQ45LM Motherboard)
      CPU: Intel Core 2 Duo (E8400) LGA775, 45nm Chip Dual Core @ 3.00GHz L1 Cache 2 x 32 KB instruction caches  2 x 32 KB data caches L2 Cache 6MB (3MB per Core) 4 KB Pages, 4-way set associative, 128 entries 4 MB Pages, 4-way set associative, 32 entries 52.81W Typical Power Consumption (65W TDP) 4GB Max Supportable RAM* Chipset: Intel(R) Eaglelake Q45 Express Chipset (North Bridge: Intel Eaglelake Q45) (South Bridge: Intel 82801IO ICH9DO) RAM: 4GB DDR2 (2 x 2GB) 1x Princeton (2GB) Non-ECC RAM Bandwidth: DDR2-800 (400 MHz, DDR2) Timings: @ 400 MHz 5-5-5-18 (CL-RCD-RP-RAS) / 23-51-3-6-3-3 (RC-RFC-RRD-WR-WTR-RTP)  @ 333 MHz 4-5-5-15 (CL-RCD-RP-RAS) / 20-43-3-5-3-3 (RC-RFC-RRD-WR-WTR-RTP)  @ 266 MHz 3-4-4-12 (CL-RCD-RP-RAS) / 16-34-2-4-2-2 (RC-RFC-RRD-WR-WTR-RTP) Model: Unknown 1x Kingston (2GB) Non-ECC RAM Bandwidth: DDR2-800 (400 MHz, DDR2) Timings: @ 400 MHz 6-6-6-18 (CL-RCD-RP-RAS) / 24-51-3-6-3-3 (RC-RFC-RRD-WR-WTR-RTP)  @ 333 MHz 5-5-5-15 (CL-RCD-RP-RAS) / 20-43-3-5-3-3 (RC-RFC-RRD-WR-WTR-RTP)  @ 266 MHz 4-4-4-12 (CL-RCD-RP-RAS) / 16-34-2-4-2-2 (RC-RFC-RRD-WR-WTR-RTP) Model: ACR256X64D2S800C6 Optical Media: HL-DT-ST DVDRAM GT31N (LG Electronics?) Firmware: 1.00 Can read: CD-ROM CD-R CD-RW DVD-ROM DVD-R DVD-RW DVD+R DVD+RW DVD-RAM DVD+R DL DVD+R9 DL Can Write: CD-R CD-RW DVD-R DVD-RW DVD+R DVD+RW DVD-RAM DVD+R DL DVD+R9 DL Network Cards:  Intel(R) 82567LM-3 Gigabit Network Connection (1000M) Graphics: Intel(R) GMA 4500 (Integrated) on the Intel(R) Q45 Express Chipset. VGA Output DVI Output PSU: 1 x LITEON 135W Laptop style PSU (Power Brick) Model PA-1131-07 Output 17V at 7.1A HDD: 1 x 320GB (WDC WD3200AAJS-22L7A0 (320 GB, 7200 RPM, SATA-II)) Monitor: None included. Sound: Realtek ALC888 (On the Intel 82801JB ICH10) Whilst in my benchmarking software there are a ton of claims that this has HDMI support and HDMI compatibility; there is no HDMI output port on the motherboard, nor are there any headers for it. With the monitors I have I can easily use DVI or some kind of converter to convert DVI to HDMI/Display Port so I’m not overly bothered by this. 
      In terms of connectivity; on the back of the device you have four USB2 ports, a serial connector, ethernet connector, an eSATA port, VGA and DVI Ports, and an impressive array of audio ports including: Line-out/Front Speakers/Headphones, Microphone, Line-In, Subwoofer/Center Out, Read Surround Speakers for 5.1 and 7.1 systems, middle surround speakers for 7.1 systems as well as a MIDI/Game Port - Joystick port. Oh and the power in. On the front you have four USB2 ports, again, headphones port and a microphone port. 
      I have used this computer for an extended period of time, from managing Microsoft Access Databases, to Excel Spreadsheets, and Google Docs this has taken everything I’ve thrown at it and shrugged it off. I’ve even gone as far as to install Photoshop CS6; and again it can handle it pretty well.
      320GB is not a lot of disk space especially with how quickly I can eat that up, so I’ve just mapped network drives to my NAS, and one of the drives in my PC, so if I need something I can drag it from there, or if I want to put something onto my main PC I can push it over there. It also allows me to share things across my network (Through the NAS) which I can access on other machines. 
      I will not be flipping this PC and putting it back on eBay, instead I will be setting it up as a workstation once I’ve set the security policies up and everything. It would make a fine addition to my collection of computers. 
      Take a look at it’s size compared to a USB3 Flash Drive and my Samsung Galaxy S8+, as you can see this is quite a small device:

      Benchmarks: For these, I am directly comparing them to the Viglen AiO as I believe they’re somewhat comparable. And as a result I will be showing the specs there, and how different they are.
      Here it is against my beast (Don’t worry, I’ve since cleaned it up and I’ve actually moved it since this picture was taken in April). 

      Weight
      Acer: 2.25KG + 610g (PSU) = 2.86KG Viglen: 5.1KG (5,164g) Difference: Acer is 57.4277% lighter RAM
      Memory Read: 6,832MB Viglen Memory Read: 7,098 MB/s Difference: Viglen AiO is 3.8191% faster Memory Write: 6,682MB/s Viglen Memory Write: 6,955 MB/s Difference: Viglen AiO is 4.00381% faster Memory Copy: 6,283MB/s Viglen Memory Copy: 6,384 MB/s Difference: Viglen AiO is 1.59469% faster Memory Latency: 105.1 ns Viglen Memory Latency: 100.0 ns Difference: Viglen AiO has 4.97318% less latency  Central Processing Unit Benchmarks:
      CPU Queen Score: 12,704 Viglen CPU Queen Score: 12,662 Difference: Acer has 0.331152% better score. (Negligible)  CPU Photoworxx Score: 3,592 MPixel/s Viglen CPU PhotoWorxx Score: 3,498 MPixel/s Difference: Acer has 2.65162% better score. CPU ZLib Score: 75.6 MB/s Viglen CPU ZLib Score: 75.3 MB/s Difference: Acer is 0.397614% faster. (Negligible @ .3MB/s difference)  CPU AES Score: 330 MB/s Viglen CPU AES Score: 328 MB/s Difference: Acer is 0.607903% faster. (Negligible @ 2MB/s Difference) CPU Hash Score: 966 MB/s Viglen CPU Hash Score: 959 MB/s Difference: Acer is 0.727273% faster. (Around 7MB/s Quicker) Floating Point Unit Benchmarks:
      FPU VP8 Score: 2,035 Viglen FPU VP8 Score: 2,102  Difference: Viglen has 3.23906% better score FPU Julia Score: 4,030 Viglen FPU Julia Score: 4,056 Difference: Viglen has 0.643087% better score (Negligible) FPU Mandel Score: 2,140 Viglen FPU Mandel Score: 2,144 Difference: Viglen has 0.186741% better score (Negligible)  FPU SinJulia Score: 1,103 Viglen FPU SinJulia Score: 1,099 Difference: Acer has 0.363306% better score (Negligible) SIMD-Enhanced Ray Tracing Benchmarks:
      FP32 Ray-Trace: 580 KRay/s Viglen FP32 Ray-Trace: 582 KRay/s Difference: Viglen is 0.344234% quicker. (Negligible) FP64 Ray-Trace: 306 KRay/s Viglen FP64 Ray-Trace: 305 KRay/s  Difference: Acer is 0.327332% quicker. (Negligible) All of those marked “Negligible” are well within margins of error. 
      Conclusion: 
      I was really surprised by these results. I was expecting it to be better than the Viglen in every way possible, and whilst it’s not (And only by a thin margin), I can’t explain why it feels snappier and more responsive, perhaps under real load conditions rather than synthetic load conditions - it is snappier. It also seems to chuck out less heat than the Viglen one, so I consider that a reasonable compromise to offset the benchmarks. There are of course other factors to consider when you’re basing things off of real world usage, quite a lot of it is subjective. I enjoy this computer though. Compared to my beast it’s tiny, underpowered and not going to run my games. But then I don’t need it to.
      Oh and it has no problem running EcchiDreams.
      Next on: "Shit I've bought from eBay" - Asus Eee PC 1011PX (AKA: Minibook 120) and Packard Bell DOTS E2 Netbooks (Coming Soon)
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Read our Privacy Policy for more information.